Issue accessing openhab:8080

  • Platform information:
    • Hardware: RPi 4 2GB - 32gb sd
    • OS: Latest Openhabian - file dated 20190805
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version:

I know this must be a completely newbie question. I’ve checked my PC firewall on linux. I’m on the same vlan and subnet of my ubiquiti switch. I cannot access openhab:8080 or ip:8080. I ran zenmap and it indicates the port is filtered. I’ve tried other Pi’s with RuneAudio or even just ssh… I keep running into the ports being filtered. What am I missing?

Thank you for the help.

You should make sure that the port hasn’t been taken by another server.

  • login to your Pi and check the openhab.log file for error messages
  • run
sudo netstat -tulpe

to check if port 8080 is in listening mode and which software is running / listening on that port

1 Like

Thank you for the feedback. I’m one of those people running an “advanced” network in my home - not the typical flat layout (e.g. 7 VLANS - with respective ACLs) . I’ve switched to a spare switch/router and am not having issues. I’ll have to investigate my primary network later…

In any case, thank you for the tip. I will add netstat to my tool belt.