Issue: all channels of all KNX things unlinked

Good evening,

Yesterday I realised that all my KNX things (each actuator is represented by a
thing in my setup) lost their linked channels. I tried to fix it by simply linking the channels again but without success. I am not able to create points of things via semantic model or to link channels in ‚things‘. OpenHAB doesn’t save the linked channel at all or returns a ‘bad request’ error. Cleaning the cache didn’t make it. Restoring a backup didn’t make it either. The KNX system itself works fine.

My setup: RPi4 bullseye/ openHAB 3.3 stable

Hopefully someone can give me advise on how to fix it.

Best regards,

Today I exchanged the SD card (RPi4 bullseye/OH3.3) with an old SD card backup of OH3.2 which worked flawlessly. I then ran the OH configuration tool and performed an update of all installed packages to their latest versions - that screwed up my KNX items. They were again all gone/ unlinked. I tried to remove the KNX binding and installed it again: no change.
So I think my problem is related to the update process or perhaps the KNX binding.

I can go back to OH 3.2 in the end but that doesn’t really solve the problem. Has anyone faced similar KNX issues with OH 3.3?


It looks more like item naming problem than binding. Can you check if you can create a new item using names which do not start with a number?

1 Like

The prohibition on Item names beginning with numbers has been there since OH1 days, although not always strongly policed by validating mechanisms.

Names must not begin with numbers.

Those who have fallen in this trap in the past find the invalid names give weird effects in rules and persistence and so on, it is not just a cosmetic issue,

Good evening,

Thanks for your suggestions and the hint of my wrong named items.
So far it worked well since OH 3.1. Probably OH 3.3 doesn’t accept it any more.
I will give OH 3.3 a new try within the next days with allowed item names.
I got the naming from an example post somewhere…

Perhaps your advice also solves a problem I posted some time ago.

Best regards,