Issue: Nothing happens when clicking on admin menus

  • Platform information:
    • Hardware: Pi4 - 32bits - SDcard 32 GB
    • OS: OpenHapbian
    • Java Runtime Environment: Zulu 11 32bits
    • openHAB version: latest (V3.something)
  • Issue of the topic: After changing UI layout code, menus on the left are not working anymore (nothing happens when I click on it)

I was modifying a layout page (code editing). Then Runing the page (Ctrl+R) doesn’t do anyhting. I then saved the code (Ctrl+S). From there, the clicking on the menus on the left doesn’t do anything.
I tried the following :

  • Returning the jsondb/UIFILE to lastest known working version > No change
  • Restarting the Pi > No change
  • Clearing cache (after stoping the instance) > No change
  • Looking 2 full hours on the community forum > Didn’t find any topic (maybe I searched wrong)
  • Creating a question for the community > result pending… :slight_smile:

I’ll stay available for any information you may need in order to help. Thanks in advance for everyone who will try to help !
Have a great day.


PS : I tried to get some more info and here what I get when running the Status command :

[22:29:38] root@openhabian:/home/openhabian# sudo /bin/systemctl status openhab.service
● openhab.service - openHAB instance, reachable at http://openhabian:8080
   Loaded: loaded (/lib/systemd/system/openhab.service; enabled; vendor preset: enabled)
  Drop-In: /etc/systemd/system/openhab.service.d
   Active: activating (auto-restart) (Result: exit-code) since Mon 2021-03-08 22:29:55 CET; 4s ago
  Process: 7176 ExecStart=/usr/share/openhab/runtime/bin/karaf ${OPENHAB_STARTMODE} (code=exited, status=255/EXCEPTION)
 Main PID: 7176 (code=exited, status=255/EXCEPTION)

Mar 08 22:29:55 openhabian systemd[1]: openhab.service: Main process exited, code=exited, status=255/EXCEPTION
Mar 08 22:29:55 openhabian systemd[1]: openhab.service: Failed with result 'exit-code'.

That shows that OH has crashed. What is in openhab.log?