[ISSUE,SOLVED] openHABian script not fully working on vanilla Debian Buster

Hi Folks,
I started installing openHABian on a fresh Debian Buster setup during hardware refresh ( just as I did many times before on older Debian setups), as described here:

This resulted in installation errors for openHAB itself and Frontail. I needed to perform some manual steps to finally succeed.

I’d like sharing it here to document for myself in case that I’m stumbling over it again in the future and to see, if others experience the same and to find out whether the documentation and/or the script itself deserves modification :wink:


OS: Linux openHAB 4.19.0-18-amd64 #1 SMP Debian 4.19.208-1 (2021-09-29) x86_64
HW: PCEngines APU2 (amd64)
JAVA: Intended to install zulu-11 64bit

Issue One

Once I started openhabian-config unattended it started as usual but suddenly it complains about some signature validation issue related to zulu Java and the installation of openHAB failed.

Therefore I checked for the installed Java versions and noticed, that two sources files for zulu were in /etc/apt/sources.list.d/. Since I had issues with the wrong Java runtime in the past, I simply tried uninstalling the Java and removing the second source file:

apt-get remove zulu-11
rm /etc/apt/sources.list.d/zulu-openjdk.list

That did the trick. After that the openHABian unattended succeeded,

Issue Two

… it tried to install Frontail and complained about a missing useradd command:

$ useradd --groups <mein-user>,openhab -s /bin/bash -d /var/tmp frontail 
/opt/openhabian/functions/helpers.bash: line 31: useradd: command not found
FAILED (adduser)

To circumvent the error, I simply re-issued the failed command with preceeding path:

/usr/sbin/useradd --groups <mein-user>,openhab -s /bin/bash -d /var/tmp frontail

and restarted the install. This time it worked.

Is some of you observing the same?
@mstormi May I ping you to get you aware of it?

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.