Issue to flash latest 32-bit image


I have tried to flash the latest 32-bit image to a Sandisk High Endurance 32 GB MicroSD via a TS-RDF5 SD Transcend USB 3.0 on Windows 10 Pro 21H2 (OS Build 19044.2486).

With Etcher Portable 1.7.9, the writing is OK, but the verification fails at 19 %.
With Raspberry Pi Imager 1.7.4, the writing is OK, and the verification fails after reaching 100 %.

I tried to flash another Raspberri Pi image, and it works fine. Any clue on why this is happening?

Thanks for your help! :slight_smile:

When using Pi Imager, which option did you use?
Pi Imager can get the Image from internal list:

Choose OS -> Other specific-purpose-OS -> Home assistants and home automation -> openHAB -> openHABian (Raspberry Pi OS lite 32 bit)

worked for me last time I tried

I used the internal list, or the custom image option and chose the image I had downloaded. I also used another MicroSD card, without success.

Bad SD card.

OK for a bad SD card. What is the explanation that regular Raspberry Pi 32-bit goes fine? :thinking:

It doesn’t use the full SD.

So I have tried the same cards on another computer, using the embedded card reader and writing the image just went fine. I did not try the USB card reader on the other machine, I will proceed with this if/when I get the opportunity. So the main suspect for now is the USB card reader, eventually the computer, or potentially both.