Issue with Homematic Thermostats


it’s me again :confused:
I am getting kind of frustrated by setting up the homematic ip thermostates over my CCU3.

The problem I have, is the following:

I did setup some rules to control the thermostates by time.
Everythings works as it should be, but then I found out (when I was standing in a cold bathroom in the morning) that the thermostat is being set back to the temp. which was set by me once over hardware-buttons it self.

Now I tracked it down to the following: when I set the temp 17degrees on the thermostat by using the hardware buttons and later on, set the temp by a rule to 20degrees, the temp is set back 17degrees after 14 to 58min.
Now what I have tried:

  1. I made sure, that there is no configuration on the CCU3
  2. That the MANU_MODE is active
  3. No other rule is setting the temp by mistake (which would be strange because of the different time it happens)

I have also played with the settings in the configuration-tab in the PaperUI. There you can change, who can control the temp in MANU_MODE. When I use “SET_TEMPERATURE_CHANGE_ONLY_BY_NONE” and “ONLY_BY_SELF”, it obviously is not changed by the rule. In the event.log I see that is is changed but since the device does not alow it, the temp on the device stays as is. So when I use “ONLY_BY_RT_TC_SC_SELF” or “BY_ALL” the problem from above happens.

I will set it to “ONLY_BY_CCU” now and see if this works (I’m at work atm, so I can not check the device (only the logs)). I will post an update here if this shows any different result.

But for now, maybe someone already had this issue with the Homematic-Ip devices and the Homematic CCU3 and can tell me what I did wrong when configuring the connection.

(Btw.: the CCU3 is configured via things-file but the thermostats are added through PaperUI (cause I thight it makes a difference (which it does not :smiley: )))

Update: changing to “ONLY_BY_CCU” did not change anything. I did set it by rule to 17 and after about 15minutes, it was changed to 20 by the system (or some troll who is living under my batroom-sink and keeps changing it always back to 20 :smiley: )

Post the rule, items and logs for the item and maybe someone can spot the issue.

Well I thing I solved the mysteri :slight_smile:
When I do it with “sendCommand()” it keep sthe temp, when I use “postUpdate()” the temp is changed back to some other value.

I will post the rules and everything when the problem appears again tonight.
All rules are active again, so if it still does not work, I will see it tomorrow morning.

Correct as post update just updates the setting (from where ever it was changed) in OH, the send command sets the temp to whatever value has been selected.

1 Like

ok I hope this teaches me the lesson to always post the rule when I have issues with any kind of rule. thanks for the help :slight_smile:

(although I though I saw it this way in another thread regarding homematic thermostats)

1 Like

Unlikely or that other thread was incorrect. See for a discussion on the difference between the two. postUpdate never leaves openHAB so it cannot be used to control the thermostat.

1 Like