Issue with network binding - can't remove thing [SOLVED]

Hi folks,

I’ve a pingable nework device that I need to remove from my things.

The item associated in .items file has been already removed.

Now I’ve the thing in PaperUI, when I try to remove I receive error 409. Via karaf I can see the thing:

network:pingdevice:CanonMG8150 (Type=Thing, Status=ONLINE, Label=Pingable network device, Bridge=null)

but nothing is present in org.eclipse.smarthome.core.thing.Thing.json

And when I try to remove via Karaf, I can see:

openhab> smarthome:things remove network:pingdevice:CanonMG8150
Could not delete thing network:pingdevice:CanonMG8150.


Any suggestion?


edit: already rebooted service and host

Did you try and remove and then re install the binding?

Binding removed, thing uninitialised … not able to remove the thing (PaperUI and Karaf).

Do I need to reinstall the binding and try again?

edit: reinstalled, same issue … not able to remove the thing

2018-06-25 15:47:18.211 [INFO ] [st.core.internal.thing.ThingResource] - Received HTTP DELETE request for update at 'things/network:pingdevice:CanonMG8150' for an unmanaged thing 'network:pingdevice:CanonMG8150'.

Did you try to clear the cache?

usually this is because you have defined it in a *.things file.
also, make sure that there are no links left over

1 Like

AHaha … I’ve checked 46148479287492319 things, but not .things file :slight_smile:
thanks guys, SOLVED :slight_smile: