Issue with REST and OpenHAB Extension for VSCode

Hello, first time poster,
I don’t know if this is the right place here.

I have an issue with the visualstudio-Code extension: I can’t get the REST integration working.
My network config is the following:
Raspbi with Openhab :
PC (windows) with editor

REST API does respond in the browser at without login

My settings.json of VSCode Extension is:
“”: “”,
“openhab.port”: 8080,
“openhab.useRestApi”: true,
“openhab.sitemapPreviewUI”: “classicui”,
“openhab.remoteLspEnabled”: true

So and finally my issue: I can’t get it to connect, I’ve get some weird ETIMEOUT stuff
The weird thing is the address in the timeout:

Error: connect ETIMEDOUT
at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1056:14) {
 errno: 'ETIMEDOUT',
 code: 'ETIMEDOUT',
 syscall: 'connect',
address: '',
port: 8080

The adress it tries to connect to is the adress from my external server, the only way it can get to this ip is through weird DNS resolving stuff.
But since theres an ip, it shouldnt try to resolve something…

I’ve tried so far different host declarations (with HTTP:// and without), even a local URL with resolving in the hosts file…

has anyone an idea what’s happening here?
the next thing I would try would be digging deeper with Wireshark.

Wireshark confirms that it is trying to connect to the external ip.

I should do more rubberduck debugging.
I figured it out: it was indeed a DNS specific problem.
At windows, theres something like a Connection specific DNS suffix in the Network configuration.
Thats normally your Domain in your network and is used if something tries to resolve an incomplete domain, like hab (instead of hab.local for example).
The extension added this suffix every time, even if only an ip was specified or a FQDN was given.
For example: if the specific suffix is mynetwork.local and the domain of the openhab system is hab.mynetwork.local, it tried to resolve hab.mynetwork.local.mynetwork.local.

but since i’ve got a domain and i use it both for external sites and internal networking (with internal things only specified in internal dns resolver) it got an external valid dns request with an sub that couldn’t internally resolved and so it got the fallback to the wildcart in the public dns zone.

I dont know if this is a general bug with resolving or how it didnt work with just the ip.
Maybe my system is simply too f*cked up.

I tried vscode fir the first time yesterday. I couldn’t get it to connect to either by name. Had to revert to ip.

But the windows machine and the dns names of openHAB are accessible everywhere. Seems some weird vscode dns issue

Yeah, but for me the IP didn’t work either, because it tried to parse the ip like a domain and added the suffix.
But after i figured it out how it messes up, i was able to go around it.