Issue with Robonect Binding

Hi guys,

Hopping someone can shed some light on the issue. I’ve had an automower for 4 years now, a 320, works great. Last year I got the robonect module which is awesome as well.

However, I’m systematically having the same connection issue when trying to link the binding to the mower. More specifically:

Status: OFFLINE - COMMUNICATION_ERROR Could not send command

Robonect binding is version 2.4.0. Openhab is version. Openhab is build 2.4.0.

My openhab runs on a virtual machine on a separate vlan. I have a firewall rule allowing my openhab to commicate through http to the mower and can see the trafic pass, so not a firewall/vlan issue.

If I go to the URL from my laptop which is on the same vlan as my mower, it requests user/password authentication. I enter the same user/password as for the openhab binging and get the requested JSON in return.

I’ve tried anything I could think of. Does anyone have a similar issue? I haven’t tried to NAT the openhab’s IP as if it were on the same LAN as the mower, but I doubt this is the issue.

It’s as if the binding was having issues with the user/password combo to go to the JSON url.



My issue is with an openhab binding. This may not directly be with openhab itself since the binding was developed by someone else, but where am I supposed to post this then?? I posted this in the add-on/binding category did I not?

I have searched and and couldn’t find an answer to the issue I have. And yes, I read the docs which does not provide any useful information in my case.

I don’t know where else I’m supposed to get help for the problem I’m having?

You didn’t read anything in that article, did you?
The point is that you’ve provided no information anyone can use to try to help you.
You need to provide your setup information and a debug log at the very least.

Do you have a solution for this?

I have the same problem. Last year it worked, now I just get this “could not send command”.

Hey Simon,

Sorry no, I gave up trying to understand where the problem came from after I was told, as you can see above, that I wasn’t giving enough information on my problem, even though I believe I gave quite a lot of useful information on my setup.

I have a full time job and 2 small kids, one of which has a rare genetic condition that causes her, amongst other things, to have insomnias that can last 3 hours about every night. So as a sleep depraved parent I just don’t have the energy to argue with people who aren’t the least bit trying to be helpful and just try to lecture me about how to post issues in forums, as if I haven’t been on the internet for the last 20 years.

Sorry I’m ranting and going out of topic, hope you find out why you have this problem. If you do find out, do let me know though if you would.


Oh and yeah, debug log, I did forget to upload one I’ll admit to that. Then again with the little time I have on my hands to actually concentrate on something for more than 15 minutes I just felt it wasn’t worth the hassle since having robonect in openhab was more something of a nice to have more than something I really needed . Maybe you can provide one Simon.


I can fully understand you, even when I have “only” 2 normal five year old children.

At the moment, I updated openhab to check if their is just a “tiny” mistake somewhere…now the mysensors binding isn’t working anymore.

The only log data I know how to give, is:

2019-05-19 21:46:18.183 [DEBUG] [ing.robonect.internal.RobonectClient] - send HTTP GET to: 
2019-05-19 21:46:18.950 [DEBUG] [ing.robonect.internal.RobonectClient] - Response body was: {"name": "Mein Automower", "id": "9BBD4C", "status": {"status": 17, "distance": 15, "stopped": false, "duration": 2368, "mode": 0, "battery": 100, "hours": 546}, "timer": {"status": 2, "next": {"date": "2019-05-20", "time": "09:00:00", "unix": 1558342800}}, "blades": {"quality": 88, "hours": 18, "days": 11}, "wlan": {"signal": -80}, "health": {"temperature": 26, "humidity": 34}, "clock": {"date": "2019-05-19", "time": "21:30:25", "unix": 1558301425}, "successful": true}

The information is within openhab, he also says the the mower is “online”. But that’s it.

Parents unite lol :slight_smile:

Yeah I wasn’t getting any response body in the logs as far as I could see, just that it couldn’t connect to the mower. I could and still can perfectly navigate to the address using a browser and log in and the page will display the mower’s status just fine. I’ll have to give it a go again and try to dive into the logs see what I can dig out.

As long as my dear old mower friend does the job, that’s what counts. Seriously don’t know what I’d do without him!

I don’t know if there is any relation, but is it possible for you to navigate to the robonect adress with your mobile phone?

Sure can, phone and mower are on the same subnet too.

I’ve tried using the ip address as well as the dns name in openhab with the same result.

Is your mower’s web access password protected? Because mine is and I suspect the issue might be that the binding wrongly sends the login information when doing the request, resulting in the mower seen as unreachable.

Are your openhab instance and mower on the same lan? If yes that would rule out firewall issues on my side.

So, good news for me, I got him back talking to openhab. Mower and openhab are in the same network and web access is password protected.

My steps were (I don’t know which was succesfull):

  • deleted the mower thing defined in PaperUi
  • added a new thing with a .things file (copied from the binding explanation)
  • copied from the binding explanation the items examples (there is a different channel description as in my item-definition before)
  • MowerStatus and mowerOneHourJob have to be on ignore, if I have them in the items.file, no item is working
  • all changes in the items-file has to be accepted by restarting the bundle in karaf
  • a restart of openhab at the end to get all working

It’s not perfect yet, but much better again :slight_smile:

Right now, also the MowerStatus is working, only the mapping does not.
It says:" Mower Status: MAP("

Good luck :slight_smile: