Issue with Z-wave and Openhab


I’m facing an issue with binding Z-wave things. I’ve just begin Openhab a few day ago and firstly trying to install :

  1. Multisensor 6 Aeotec (plugged in USB)
  2. Smart Plug HKZW6SO05

Once I installed OpenHab last Snapshot version with Zulu 11, I’ve plugged my Z-wave controller, added as a thing and this work.
But, when I’m trying to configure the 2 other thing, they are discovered but remain as unknow device.
I unplugged it, trying to wake it up several time, re install OpenHab, trying Open Jdk 11 instead of Zulu, pressed 3 times the z-wave button, reboot the machine but nothing work.

I’m a bit lost, I use Raspberry pi 4 but I try it with my Window and Linux computer and nothing work too.

My config:

  • Raspberry pi 4 running on: Linux verison 5.4.83-v7l+
  • ARMv7 processor rev 3
  • Zulu jdk 11.0.901
  • Openhab last snapshot for now, I also tryed with stable version yesterday
  • Z_wave controller: Z-wave Serial Controller
  • Binding Z-wave: just dowloaded recently so last version

I’ve seen maybe the issue is related with the database…but I’m a bit confused cause Multisensor is not really a new composant…

Anyone could help me ?

Wish you a good day

There are 2 different “last snapshots”. What version exactly? What Z-Wave controller are you using?

It is always recommended to Include through the binding and it is required for a secure inclusion. Using the button is not recommended.

Did you follow the binding documentation to collect DEBUG logs? If so this viewer may help.

If you did not do this remember this forum is not a substitute to reading the documentation…

How to ask a good question / Help Us Help You - Tutorials & Examples - openHAB Community

Thanks for your reply, i’m using the Z-wave bridge controller ACC-UZB3-E-BRG UZB EU.
Snapshot version : distro/3.1.0.SNAPSHOT

Yes, I guess I included it with the binding with scan with PaperUi but at the beginning the Multisensor wasn’t detect until I pressed the button to wake it up. I already read the documentation about the controller and things, that why I’m asking some help… Log show me the same warning but not error: SerialMessage class null is not implemented and Todo: Implement processing of Request Message
And another warning : Manufacturer data not know

Why are you using an early snapshot version that may be unstable and broken? For the latest version you should be using the 3.0.0 stable release. Sometimes people manually install a snapshot zwave binding to get the latest database entries but for most everything else you should stick to a sizable build unless a developer says otherwise.

I already trying the stable version earlier that why I’m trying this one…

Maybe there is a misunderstanding? When the controller is put into inclusion mode (through the binding), the device needs to be put in inclusion mode as well. Usually that is done by pressing a button e.g. three times. For the Multisensor it is a bit complicated. From the documentation:

“1. Power on MultiSensor. The MultiSensor’s LED will blink slowly when you short press the Action
2. Let the primary controller into inclusion mode (If you don’t know how to do this, refer to its manual).
3. Press the Action Button.
4. If the inclusion is success, MultiSensor’s LED will be kept turning on for 8 seconds when you short
press the Action Button. If the LED is still in slow blink, in which you need to repeat the process from
step 2.”

With the Aeotec Multisensor 6 powered by USB this should work ok as they are considered mains powered in this situation, so no “wakeup” procedure needed as with battery powered devices.

Mine were already included when I switched to OH3 so I cannot tell whether there might be an issue with the database in OH3, leading to issues when including the devices…

The other device is unknown to me.

Some people use a button on the controller for inclusion mode. I think I may have misunderstood,

They also mention the Paper UI but are running 3.1.0 Snapshot which has no Paper UI.

Confusion reigns supreme here…

The plug needs the latest 2,5 or 3,x snapshot binding but is should be manually installed on a stable system, not a snapshot one.
There are 4 different entries for the multisensor 6, depending on firmware version. A snapshot binding version would be safest for that too.

Thank you for your reply, unfortunately I already do that… For now when I press the Action button the LED kept turning on during 8 s with green color which mean that the inclusion work and that make sense cause OpenHab recognize it as a Things but remains unknow. That really weird, I tried several way to include it in Openhab and nothing work. As Bruce said, I changed the OpenHab version to the stable one but no change…

You need a stable version with a manually installed snapshot binding to get the binding with updated database. This script may help and the README describes the manual; process.

Zigbee and Z-Wave manual install script - Tutorials & Examples - openHAB Community

1 Like

So, I just try this script and unfortunately don’t work too. It change the snapshot binding as intented cause my previous discovered node disapear but I have the same error:

13:48:43.765 [INFO ] [hab.event.ThingStatusInfoChangedEvent] - Thing ‘zwave:device:1c30b03f01:node2’ changed from ONLINE to REMOVING
13:48:43.808 [INFO ] [hab.event.ThingStatusInfoChangedEvent] - Thing ‘zwave:device:1c30b03f01:node2’ changed from REMOVING to REMOVED
13:48:43.825 [INFO ] [hab.event.ThingStatusInfoChangedEvent] - Thing ‘zwave:device:1c30b03f01:node2’ changed from REMOVED to UNINITIALIZED
13:48:44.022 [INFO ] [hab.event.ThingStatusInfoChangedEvent] - Thing ‘zwave:device:1c30b03f01:node2’ changed from UNINITIALIZED to UNINITIALIZED (HANDLER_MISSING_ERROR)
13:48:56.210 [WARN ] [zwave.discovery.ZWaveDiscoveryService] - NODE 2: Device discovery could not resolve to a thingType! Manufacturer data not known.
13:48:56.224 [INFO ] [ig.discovery.internal.PersistentInbox] - Added new thing ‘zwave:device:1c30b03f01:node2’ to inbox.
13:48:56.226 [INFO ] [openhab.event.InboxAddedEvent ] - Discovery Result with UID ‘zwave:device:1c30b03f01:node2’ has been added.
13:48:59.050 [WARN ] [l.serialmessage.ZWaveCommandProcessor] - SerialMessage class null is not implemented!
13:48:59.056 [WARN ] [l.serialmessage.ZWaveCommandProcessor] - SerialMessage class null is not implemented!
13:48:59.061 [WARN ] [ave.internal.protocol.ZWaveController] - TODO: Implement processing of Request Message = – (0xa8)
13:49:04.299 [INFO ] [openhab.event.InboxRemovedEvent ] - Discovery Result with UID ‘zwave:device:1c30b03f01:node2’ has been removed.
13:49:04.326 [INFO ] [hab.event.ThingStatusInfoChangedEvent] - Thing ‘zwave:device:1c30b03f01:node2’ changed from UNINITIALIZED to INITIALIZING
13:49:04.358 [INFO ] [hab.event.ThingStatusInfoChangedEvent] - Thing ‘zwave:device:1c30b03f01:node2’ changed from INITIALIZING to OFFLINE (BRIDGE_OFFLINE): Controller is offline
13:49:04.368 [INFO ] [hab.event.ThingStatusInfoChangedEvent] - Thing ‘zwave:device:1c30b03f01:node2’ changed from OFFLINE (BRIDGE_OFFLINE): Controller is offline to ONLINE
13:49:04.403 [INFO ] [openhab.event.ConfigStatusInfoEvent ] - ConfigStatusInfo [configStatusMessages=[]]

As you can see the manufacturer is still not know…

Try deleting (NOT exclude from network) & re-adding the Thing to OH to get the new settings.

Thank for your reply, you are very helpfull, but nothing work…

This normally means the device is not communicating with the controller. For a battery device, it is common for it to be needed to be woken up for this communication to occur. I see you have this connected via USB power - was it included into the network while connected to the USB? To be sure, I would exclude it, and re-include it, all while connected to USB power.

Yes, all the handling was made with USB connect. I don’t have any battery for now. I tried what you said, I exclude the all devices, and then re-include it with scan but still unknow.

Is the device communicating at all? It’s really hard to provide a lot of help with no information. Have you checked the logs to find out what is happening???

So, I will explain in detail what I do to connect my thing on Raspberry pi 4:

  • Firstly, I go to the OpenHab UI located in localhost:8080
  • I created a new Things with the plus symbol
  • I choose the Z-wave Binding
  • I add manually the Z-wave Serial Controller (Bridge)
  • I select Serial Port: /dev/ttyACM0 and click on Create Thing


  • Click on plus symbol
  • Click on Z_wave Binding
  • Push the action button of Multisensor 6 during 20 s to reinitialize it. It flickered red and then stop
  • Then push the action button, flickered green
  • I click on scan in the UI
  • Discovered things appear, I had all

So, I can see the Thing connected

And the the log said: Device discovery could not resolve to a thing type, manufacturer data not know

I am on OH 3.0, no snapshot for the Z-Wave binding. In my case the Multisensor is shown with all parameters and channels in the GUI as it is recognized as a ZW100 as it should be.
Maybe there is a new variation with a different firmware and it is not recognized as the current database entries do not apply?

I think I saw 6 entries depending on firmware.

Yes, it is the 6 node about the same objet. Each time I reinitialize the Things, OpenHab create a new node

I’m not sure I could identify my own Multisensor with the information given in “Thing Properties” in the GUI. I can identify the zwave_manufacturer (in my case 134) and the zwave_deviceid (100), but I cannot identify the firmware version. Even in the XML file I cannot see this information. :astonished: