Issues installing snapshot Zwave jar file: could not resolve module

In OH 3.1.0.M3, I tried to install the snapshot Zwave jar file (timestamp 2021-04-25-03:36) from the ci platform.

I followed the instructions in OH3 Smartthings Add-on Discovery not working - #7 by Antony_Price (although this is an other binding, the same installation rules I’d expect to apply):

  • I manually removed the GUI-installed zwave binding
  • Copied the new .jar to the addons directory /usr/share/openhab/addons, with as far as I know correct username, group and file access bits:
-rw-r--r-- 1 openhab openhab 3.5M Apr 26 11:22 org.openhab.binding.zwave-3.1.0-SNAPSHOT.jar
  • Restarted OH with systemctl
  • I tried to activate the jar via only copying the jar file in the /usr/share/openhab/addons directory, and (later), also via mentioning “zwave” in addons.cfg.

But whatever I do, I keep the error message Unresolved requirement: Import-Package: org.osgi.framework; version="[1.9.0,2.0.0)":

2021-04-26 13:46:49.443 [WARN ] [org.apache.felix.fileinstall        ] - Error while starting bundle: file:/usr/share/openhab/addons/org.openhab.binding.zwave-3.1.0-SNAPSHOT.jar
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.zwave [222]
  Unresolved requirement: Import-Package: org.osgi.framework; version="[1.9.0,2.0.0)"

	at org.eclipse.osgi.container.Module.start( ~[org.eclipse.osgi-3.12.100.jar:?]
	at org.eclipse.osgi.internal.framework.EquinoxBundle.start( ~[org.eclipse.osgi-3.12.100.jar:?]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundle( [bundleFile:3.6.4]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundles( [bundleFile:3.6.4]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startAllBundles( [bundleFile:3.6.4]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess( [bundleFile:3.6.4]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.process( [bundleFile:3.6.4]
	at [bundleFile:3.6.4]
2021-04-26 13:46:52.703 [INFO ] [zwave.handler.ZWaveControllerHandler] - Attempting to add listener when controller is null
2021-04-26 13:46:52.908 [INFO ] [zwave.handler.ZWaveControllerHandler] - Attempting to add listener when controller is null
2021-04-26 13:46:53.621 [INFO ] [e.automation.internal.RuleEngineImpl] - Rule engine started.
2021-04-26 13:46:57.931 [INFO ] [ve.internal.protocol.ZWaveController] - Starting ZWave controller

Result is:

openhab> list -s | grep zwave                                                                                                                         
222 │ Installed │  80 │      │ org.openhab.binding.zwave
233 │ Resolved  │  80 │ 3.1.0.M3                │ org.openhab.binding.zwave

This issue seems to be close. It gets a similair error message, but not close enough.

Any idea’s ?

I am not sure if the SNAPSHOT binding is compatible with M3. I know OSGi was updated and I think it happened after M3.

Aha, that is something I overlooked. I see in openhabian-config that I used the Milestone branch, so I have to switch to snapshot than, I suppose.

Thanks Bruce!

Unfortunately, yes,

No big deal, now it works! Thanks !

According to the instructions in Problems when upgrading to OH3 snapshot this is what I did:

  • shutdown Openhab
  • cleaned the cache (not sure whether this was a must, but it is not much work)
  • run openhabian-config,
  • in the menu item openHAB related I found the openHAB snapshot
1 Like

I think up-grading is supposed to clear the cache but I have had to do it manually at times.