Issues with AEOTEC Z-Stick Gen5 and AEOTEC KeyFob 4 Button - HABmin is only discovering "Unknown Device"


I was already raising the issue on github (
since the Z-Stick Gen5 is listed as “requires review” in CDJackson device database, but
CDJackson asked me to hunt in the forum.

So again the problem in Details:
Z-Stick Gen 5 ( Offline pairing (z-stick button) works fine and both devices are indication a connection
Adding the KeyFob_
I also had the same issue with a borrowed Devolo KeyFob_ in HABmin is producing only a “Unknown Device”.

Other Z-Wave Devices are recognized without any problem using Z-Stick:
-Aeotec Multisens 6_
-Fibargroup Double Swith 2_
-nodon smart plug, discovered as ID-RF_

CDJackson suggested it might have to do with the KeyFob beeing a battery device. (seems plausible for me since I was trying with 3other borrowed battery devices and all came up as “unknown”

Since the Z-Stick is supporting only the “offline inclusion” (you have to unplug the stick and use the button on the stick to include to the device) you cant use the HABmin device discovery function to include the KeyFob with the controller. But if you are doing the pairing offline, both devices are indicating a successful inclusion with the designated led codes.
If you want to add the included device to HABmin, you have to plug in the Z-Stick again and since the inclusion was done offline before, the Z-Stick not the KeyFob now provides the device information for HABmin. So there should be not issue with the KeyFob not being awake?
I also did a complete offline exclusion and mad sure the KeyFob was awake when using the dicovery function in HABmin to include the KeyFob. Same result “unknown”

So the issue seems to be all around Z-Stick requires offline inclusion and HABmin is not accepting offline included battery devices.

Has anyone run into similar problems with Z-Stick, battery devices (switches) and “unknown devices” in HABmin?

Tanks for you help in advance


here is the configuration of my environment:

OH2 Version: 2.0 (running on Raspberry Pi 3 with latest Raspbian Jessie with PIXEL
Version: April 2017
Release date: 2017-04-10
Kernel version: 4.4)
Binding Version: 2.0.0 (and also with Snapshot binding 2.1.0 of 6th June 2017)
Device name: Aeotec AEOEZW090-C controller & Aeotec Key Fob ZW088
Device version: Controller: Z-Stick Gen5 AEOEZW090-C KeyFob: Gen5 (both German/Europe editions)

This is an incorrect assumption. The controller does not contain all the information the binding needs to figure out what kind of device it is. Once it is included offline and plug the controller back into the server, you need to wake up the KeyFob (or any other battery powered device) multiple times to give the binding a chance to gather enough information to figure out what sort of device it is. The procedure for waking up the device differs from one device to another but in my experience with a few battery powered devices, you press the same buttons or do the same thing you would do to include the device with the controller.

I agree with Rich. I have the same Stick with openHAB 2.0 stable and the z-wave binding from Chris and just learned the hard way as zwave newbie on what “inclusion” means.
But first of all - I always used inclusion mode from within HABmin to include my battery devices. When activating inclusion in HABmin you have 30 seconds to put the device in inclusion mode and it should be close to the stick at that time.

Next I had to wake up my battery devices manually (according to the vendors description for wake-up) between 3-10 times for each device until they were fully initialized.

So I guess you should put your battery device close to the stick and then start the wake-up procedure several times. Otherwise you would have to wait for the device internal wake-up interval to fire several times, which can take a couple of days then until fully initialized.

Not so simple, the zwave stuff, as I thought.



thanks Rich and finally Uwe for putting me in the right direction.
Issue solved
I was trying to do the manual wake up to the unknown device, but it somehow didnt work out for me, but I found a way to get it done right in HABmin right when you include the Thing via HABmin:

  1. unplug the Z-Stick, press the button on the Z-Stick to start inclusion (stick is flashing blue)
  2. start the inclusion on the KeyFob by pressing short the learn button on the back (or if you are still in setup mode the Button 4 lower rigth on the front side) the inclusion will be indicated at the stick with a solid blue light
  3. plug in the Z-Stick again and wait for it to be recognized (online)
  4. (and here timing is essential) including the KeyFob using HABmin while the KeyFob is awake. To wake up the KeyFob manually you have to press the learn button on the back for 3 seconds. But it only wakes up for 8 sec. So the sequence hast to be exactly:
    =>wake-up KeyFob
    =>start Z-Wave inclusion on HABmin within 8 sec.
    =>wait for the KeyFob to be discovered as Thing: ZW088 4 button keyfob - Gen 5
    If the device is still coming up as unknown or, what happened for me, came up as a other device, just delete the Thing again and redo the sequence.
    I had to do it multiple times before the inclusion was done right
    So if you wake up the KeyFob after starting the inclusion in HABmin or if you are to slow starting the inclusion in HABmin after waking up KeyFob, it will always come up as unknown device at the initial inclusion. If you are not getting it right you have to try Uwe’s way in just manually waking up the KeyFob up to 10 times…

As far as cdjackson, this process should solve all the issues with Z-Stick and battery z-wave devices. You just have to look up the way to manually wake-up the device (be aware that there might be a difference in wake-up time of the battery device while inclusion to the Z-Stick and and manual wake-up time for integration into HABmin later on, as you can see below)

And another funny thing about documentation
There was an issue with the manual of the device since the new standard manual didnt tell you that the wake-up time for manual wake-up is only 8sec. while the wake-up while inclusion is 30sec. (found the information only in an old standard manual)

So again thanks to Rich and Uwe.


PS: …and yes, Uwe Z-Wave is not so simple as I thought. Just don’t try to use the razberry board on a raspberry pi3 as a zwave controller…you will learn about ports and onboard wifi and all this sort of things :slight_smile:

Hi Caesar,

Good to hear you found a way. But to my understanding of zwave so far you don’t need to start inclusion mode on openHAB for further initialisation progress but just need to wake up the device several times. Otherweise you get doubled nodes, at least I made this experience.
However, if you have found a stable procedure for you this is good.

I still fight with my devices as they currently do not show the open/close status changes in openHAB anymore since openHAB restart.
So I recommend to restart your ooenHAB and check that all still performs as intended.




I did a restart and everything worked fine.
I only gad one some issues when I tried to start the web interface before the openHAB server completely.
then I was not able to get any status , not z-wave and no other bindings.
So I am planning to include more Z-wave devices and keep the forum posted.