Item connected to Channel does not function

OH2 snapshot from 5/16 under Windows 8.1.
Aeotect ZW111 nano dimmer f/w v1.2 with their zstick controller.

Created a Switch Item and Dimmer Item, connected each to the appropriate Channel on the ZW111 dimmer Thing.

Within “HABmin -> Configuration -> Things -> Z-Wave Node 2 -> Description” I can toggle both the Switch and Dimmer items with the ON/OFF toggle presented, and this makes the associated light bulb turn ON and OFF as expected.

Within “HABmin -> Sitemaps -> Home -> Things -> Z-Wave Node 2” I am also presented with the 2 Items and their respective ON/OFF toggles. The Dimmer toggle works and changes the light bulb state, but the Switch toggle does nothing.

Also, is there no feedback from this device? Toggling one does not update the state of the other. Or is it expected that each Channel is completely independent and therefore may not represent the actual state of the device?

Also, PaperUI does not update the network key config entry, as verified by Aeotec’s backup utility.

Also, PaperUI does not seem to understand when the USB controller has been pulled, and change the state from ONLINE to something else.

Also, openHAB2 should read the config of the dimmer during initialization and reconcile the differences.

Also, if I delete the ZW111 dimmer Thing, then use SUC query and add the dimmer Thing back in, the Dimmer Item is somehow and unexpectedly already attached to the corresponding Channel on the brand new Thing (well, most of the time it is, though occasionally not). But the Switch Item is not attached (as one would expect).

How did you create the 2 items? (PaperUI or config files?)

If you used PaperUI, break the links from the channels, delete the Items, then remove the Thing and try again from scratch.
Any useful info in the logs?

I did not edit any files.

To create Node 1 (the controller) I installed Serial and Z-Wave, then did a manual add of a Z-Wave Controller Thing, set the COM port.

To create Node 2 (the dimmer) I pulled the controller out of the USB port, set it to Inclusion mode, and added the dimmer. Upon re-insertion of the controller I used SUC query to download the current network config.

I did not use OH2 to set the controller to Inclusion mode, as I do not see a method of doing so. Maybe it is hidden somewhere. Would be nice to do so that I can add the device in Secure mode.

Regarding some of the notification issues, I figured out Parameter 80 on the dimmer. There is still the issue in HABmin -> Sitemaps that the Switch toggle does nothing. Works directly on the Thing and in PaperUI -> Control.

I believe that if you use HABmin, you can put the Controller in inclusion mode (I don’t remember how).
I used to add my Z-Wave stuff in the same way like you (unplug the controller and perform a manual inclusion)

Can you post the contents of your sitemap file to check them?

Also: It’s not clear for me how you created the Items (not Things) in your OH2 system (PaperUI with simple mode on or off?)

In openHAB2 there is a discovery button (both in HABmin and PaperUI). This will put the controller into inclusion mode for 30 seconds. If using HABmin, there will be a popup when this starts and stops.[quote=“gfischershaw, post:1, topic:28615”]
Also, if I delete the ZW111 dimmer Thing, then use SUC query and add the dimmer Thing back in, the Dimmer Item is somehow and unexpectedly already attached to the corresponding Channel

This is probably related to this -:

1 Like

Created the items in PaperUI. I vaguely recall a simple mode switch but I am unable to find such a toggle at this time.

What I found is that the Switch was listed in the json item db file many times. I had only created it once. To get rid of it I had to delete that file, plus the channel link db file, the backup files and all the tmp files. Otherwise it would keep appearing in the UI, but could not actually be deleted from the UI (404 not found).

Now I have the Channel linked (though the ON/OFF toggle in HABmin does not show up in the Thing Description until you move to a different page and back again).

“Restore Last Value” on the brightness gets reset to default when the channel ls linked to an item. And now I see that an unnamed link also appears on that channel in addition to the one I just created. Error when trying to delete it because it does not exist.

Just wiped the install, downloaded the latest snapshot (in case there was some change) and installed it (Standard Setup).
PaperUI: Install HABmin, Serial, Z-Wave. Added Z-Wave controller Thing. Accepted Dimmer in Inbox. Created Item: Category: DimmableLight, Type: Dimmer.
HABmin: Linked new Item to Dimmer Channel. Set “Restore Last Value” to 100%. Save.
HABmin: Navigate to Sitemaps -> Home -> Things -> Dimmer. Toggle ON/OFF Dimmer Item presented. Light goes on to previous value, not 100%.
HABmin: Navigate back to Dimmer Thing Channels. No Channel Binding is shown. Attempt to create the binding to the Item again and the UI refuses (says nothing, just won’t accept Save, only Cancel).

Am I doing something incorrect, or does this stuff not actually work yet?

“KitchenTestLamp”: {
“class”: “org.eclipse.smarthome.core.items.ManagedItemProvider$PersistedItem”,
“value”: {
“groupNames”: [],
“itemType”: “Dimmer”,
“tags”: [],
“label”: “Kitchen Lamp”,
“category”: “DimmableLight”
“KitchenTestLamp -\u003e zwave:device:63c4ec04:node2:switch_dimmer”: {
“class”: “”,
“value”: {
“channelUID”: {
“segments”: [
“itemName”: “KitchenTestLamp”

Conscious that this is a little late but I also installed the dimmer switch this weekend and I’m having similar issues. Did you every manage to resolve them?

Initially, when I included the item I was able to control it through paperUI. However, I also experienced the problem that the dimmer switch doesn’t seem to send any thing to openhab, no state change, power consumption, etc…

The morning after I included the item I realised that the node doesn’t seem to be communicating with the controller anymore. I had to exclude the device, then re-included it. Worked for a bit but then following morning, the same thing happened again.

Edit: using OH2 and also had to update the z-wave binding to the latest snapshot for it to even recognise the device

Edit 2: after doing a little research I came across this. Looks like I might do a bit more manual configuration before it works. Haven’t been able to try this yet as it’s still not communicating with my controller, so may be a project for another day.