Item value not showing up in basicUI but showing in paperUI

  • Platform information:
    • Hardware: Raspberry PI 4 4GB
    • OS: buster
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version: openHABian 2.5 11-1
  • Issue of the topic: item value not showing up in BasicUI but showing up in paperUI
  • Please post configurations (if applicable):
    • Items configuration
      Number OU_Porch_Temperature “Temperature” (OU_Porch, gTemperature) [“Temperature”] {channel=“mqtt:topic:5db0844c:temperature”}

also “c” after the value isnt showing up in the paper or basic UI

this is a BMP280 sensor , humidity and pressure you can see

i have more BMP280 sensors and all of them i can see the basicUI ok and they are using the same item configuration

this has been working before

Change the text in your item file to

Number OU_Porch_Temperature "Porch temperature [%.1f %unit%]

This will add the temperature

1 Like

How come the other sensors are ok?

Will try that later ,many thanks

How far do I alter the sitemap to include this?

In your sitemap your add the item as follows

Default item=OU_Porch_Temperature

Without any label. (if you add a label it will overwrite your label from the .item file)

In general, “you get what you ask for”.
So if an OH2 Item does not have a [state presentation] data embedded in its label string, you get no display.

Some binding channels can “suggest” a [state presentation] when linked to an Item, a default. So then you do get to see something even if you didn’t ask.

Understanding “some show up and some don’t” becomes a question of understanding the detail of what channels you linked them to. In OH2 it’s mostly zwave making “suggestions”.

You can override what the Item thinks, by giving a [state presentation] in the label= string of a sitemap widget.

To complete the story, you can deliberately suppress state display with an empty [] presentation - you might do that for a switch widget, to stop ON/OFF displaying alongside the slider.

1 Like