Item values not shown on iphone app but in browser


I get some items from remote openhab that show certain disk usages.

One example item:

String RemoteVeracryptHome     "VC Home "      <diskused> { channel="remoteopenhab:server:cedc5f1c5e:Veracrypt_Home" }

In Visual Studio Code I can see the correct value, when I hover over the item.
When I use the web frontend, all items are visible.


But when I use the openhab iPhone app these item values are not visible. Everything else looks fine.

Thanks, Markus

You should add “[%s ]” to the label in order to value like:

"VC Home [%s]"

Good point.

But I already tried that with other items. Ok, here is the complete list of items

String RemoteVeracryptHome     "VC Home "          <diskused> { channel="remoteopenhab:server:cedc5f1c5e:Veracrypt_Home" }
String RemoteVeracrypBilder    "VC Bilder"         <diskused> { channel="remoteopenhab:server:cedc5f1c5e:Veracrypt_Bilder" }
String RemoteVeracrypDocs      "VC Docs "          <diskused> { channel="remoteopenhab:server:cedc5f1c5e:Veracrypt_Docs" }
String RemoteVeracrypLetsenc   "VC Letsenc "       <diskused> { channel="remoteopenhab:server:cedc5f1c5e:Veracrypt_Letsenc" }
String RemoteVeracrypCamcorder "VC Camcorder [%s]" <diskused> { channel="remoteopenhab:server:cedc5f1c5e:Veracrypt_Camcorder" }
String RemoteVeracrypNextcloud "VC Nextcloud [%s]" <diskused> { channel="remoteopenhab:server:cedc5f1c5e:Veracrypt_Nextcloud" }

Here is the extract from the sitemap

   Text item=RemoteVeracryptHome      valuecolor=["#ff0000"]
   Text item=RemoteVeracrypBilder
   Text item=RemoteVeracrypDocs
   Text item=RemoteVeracrypLetsenc
   Text item=RemoteVeracrypCamcorder
   Text item=RemoteVeracrypNextcloud

Ups, I should have been more precise. I was talking about the label in the sitemap file.

No problem

But it makes no difference. Still no value displayed. This is my new test label:

Text item=RemoteVeracrypNextcloud label="Sitemap Label [%s]"

I never noticed such behavior before. And I have a quite complex sitemap with many items. Locating one of those items somewhere else within the sitemap also does not help.

I have other remote items that are displayed without any issue.

By the way: when the values are refreshing from the remote openhab system, REFRESH is displayed in the app for a short while.

Out of clues :no_mouth:

Thanks for your support :blush:

I now found a solution :slight_smile:

  1. changed the remote items to Number
  2. changed my remote rule to handle the disk usage as number, not as string (executeCommandLine returns a string!)
  3. changed my local items to Number

Voila! It works.
Is there a reason why the string values are not shown in the iPhone app correctly?

Many thansk and kind regards

I don’t use any Mac device. Any comment from me on that question would be somewhat offtopic. :face_with_hand_over_mouth:

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.