Items do not appear in Homekit through UI OH3

  • Platform information: OpenHABian
    • openHAB version: 3.0.1

I have tried to find the answer to my question as best I can on this forum, but no luck. We recently moved and I decided to start fresh with the new OH3. I decided to use the UI for seting up my items and so far so good. The problem starts when I add metadata for Homekit tagging: No accessories show up in the Home app.
I tried everything that I could think of but when I realised that openhab:homekit list came up blank I reverted to .items file setup. All the test items that I have in the file with Homekit tagging shows up immediately, no problems. In addition, GA tagging works from both UI and text config.

What am I missing? I have tried to tag simple dimmer items as well as more complex group items with main tag and sub-items with the more specific types (making sure that the mandatory one is included).
Thanks in advance!

it is a bug in OH3.0 release - adding metadata via UI does not trigger re-evaluation of the homekit configuration. it was fixed in the recent snapshot of homekit binding.
workaround you prefer to stay on stable version - you can stop and start homekit binding via karaf - that would trigger the re-evaluation of the configuration

Thank you very much for your quick reply.
bundle:restart did the trick.

Sidenote, where do I find the bug reports?

1 Like

you kind find and report bugs here

you can search for “homekit” there. in order to see also fixed bugs remove “is:open” from search

the bug i was referring to it is that