Items won't display data

I’ve recently added a Aeotec Multi Sensor 6 to my set-up, and its data displays in PaperUI but for some reason it won’t display in my sitemap (tho it did do initially, until I messed up the zwave settings and had to re-include the device).

My item file has the same settings as are in the binds example, here:-

Is anyone able to suggest how I might track down and cure the problem, please?

when you reincluded it did you update the Item? If you are on OH 1, the node number almost certainly changed and you need to update the Item binding config accordingly. In OH 2, the channel ID changed, for the same reason.

hi Rich, thanks for replying.

I changed the number in my items file (below) from 3 to 4, to match the change of nodeID that PaperUI tells me the device is using.

There’s no ‘channel ID’ that I can see…?

Switch    Motion_GFToilet     "Motion [MAP(motion.map):%s]"     <motion>    (FF_Office, Wemo1)    { zwave="4:command=sensor_binary,respond_to_basic=true" }
Number     Alarm_GFToilet         "Alarm: [%s]"             <alarm>        (FF_Office, Wemo1)    { zwave="4:command=alarm" }
Number     Temp_GFToilet         "Temperature: [%.1f °C]"     <temperature>    (FF_Office, Wemo1)    { zwave="4:command=sensor_multilevel,sensor_type=1,sensor_scale=0" }
Number     Humid_GFToilet         "Humidity: [%.0f %%]"         <humidity>    (FF_Office, Wemo1)     { zwave="4:command=sensor_multilevel,sensor_type=5" }
Number     Lumin_GFToilet         "Luminance: [%.0f Lux]"     <sun>        (FF_Office, Wemo1)     { zwave="4:command=sensor_multilevel,sensor_type=3" }
Number     UV_GFToilet         "Luminance: [UV index %d]"     <sun>        (FF_Office, Wemo1)     { zwave="4:command=sensor_multilevel,sensor_type=27" }
Number     Battery_GFToilet     "Battery: [%d %%]"         <battery>    (FF_Office, Wemo1)     { zwave="4:command=battery" }

You should tell us wether you are using OpenHAB 1 or 2? Channels ID’s are only used in OH2.

Oh, I just saw you are writing about PaperUI. Therefore I would assume you are using OH2. In this case, were have you get your binding informations (“zwave=4:…”) from? This type of binding association is related to OH1 installations. If you are using OH2, this will not work. You have to use channel IDs (taken from PaperUI or Habmin). If you aren’t yet familiar with the OH2 architecture, you should read the tutorials first (docs.openhab.org). Furthermore Rich has posted a very useful migration tutorial here in the forum.

Are you using the 2.0 zwave binding or the 1.9 SNAPSHOT zwave binding? If the 2.0 binding, you need to look into your Inbox for the zwave devices, accept those you want to control. Then in PaperUI you go to Configuration -> Things, select the zwave device and it will list all the channels associated with that device.

You assign the channel to an Item using { channel="channelID" } which is that string that starts with “zwave:device:” in the screenshot above.

I’m using OH2.

The binding/item format I gave above using is the one given in the link I gave in my first post. I followed a link to that from another topic post, which I’m pretty sure was asking about set-up for OH2, tho I could be wrong.

But anyway, I’d tried using the channel format too, but also without success. However…

I just tried again, and looked to see if there was anything in the log, and saw a reference to MAP transformation. so i tried installing that, but still no luck - at least, not until I stopped and the restarted openhab2. It did start to work then.

So thank you both for your posts, they pointed me in the right direction and have got me sorted.