Jar file installed,nothing happens

installed openHAB 3.2.0 on RPI 3B+ webUI works and I could bind my Solar Edge account.
placed “org.openhab.binding.sonoff-3.2.0-SNAPSHOT_2.5R10.jar” in the addons folder changed owner and permissions but nothing further happens?
what am I missing?

what do you expect to happen ?
Any error message in /var/log/openhab/openhab.log ?

As Wolfgang_S already pointed out, see if there are any hints in the logfile. Placing a jar-file into the addons folder does not take care of dependencies (in contrast to an installation of a binding via GUI). Maybe you need to install something additionally to make the sonoff jar work.

If I’m not mistaken " nothing" would happen if the binding is installed, in other words it will NOT show as installed as other bindings. However it is possible to create things for that binding.

1 Like

Thanks for the reactions.
I placed th .jar file in this folder: /usr/share/openhab/addons/org.openhab.binding.sonoff-3.2.0-SNAPSHOT_2.5R10.jar
This is the last part of bundle:list were you see I added Kodi and SolarEdge as bindings through the UI
231 │ Active │ 80 │ 2.1.2 │ Units of Measurement Reference Implementation
232 │ Active │ 80 │ 2.1.0 │ Units of Measurement Common Library for Java
233 │ Active │ 80 │ 1.4.18 │ XStream Core
239 │ Active │ 80 │ 3.2.0 │ openHAB Add-ons :: Bundles :: Persistence Service :: RRD4j
240 │ Active │ 80 │ 3.2.0 │ openHAB UI :: Bundles :: Basic UI
241 │ Active │ 80 │ 3.2.0 │ openHAB UI :: Bundles :: HABPanel UI
242 │ Active │ 80 │ 3.2.0 │ openHAB UI :: Bundles :: Icon Set :: Classic
243 │ Active │ 80 │ 3.2.0 │ openHAB Add-ons :: Bundles :: SolarEdge Binding
244 │ Active │ 80 │ 2.6.0 │ JUPnP Library
245 │ Active │ 80 │ 3.2.0 │ openHAB Add-ons :: Bundles :: Kodi Binding
246 │ Active │ 80 │ 3.2.0 │ openHAB Core :: Bundles :: Configuration UPnP Discovery
247 │ Active │ 80 │ 3.2.0 │ openHAB Core :: Bundles :: UPnP Transport

Nothing to find for Sonoff.

I added also a text file as suggested with the following and that seems to be accepted, after a text correction, according to the log file:
11:26:36.321 [INFO ] [del.core.internal.ModelRepositoryImpl] - Loading model ‘sonoff.things’
11:26:36.345 [WARN ] [del.core.internal.ModelRepositoryImpl] - Configuration model ‘sonoff.things’ has errors, therefore ignoring it: [1,15]: missing EOF at ‘:’

11:34:42.178 [INFO ] [del.core.internal.ModelRepositoryImpl] - Loading model ‘sonoff.things’
12:03:56.541 [INFO ] [del.core.internal.ModelRepositoryImpl] - Loading model ‘sonoff.things’

This is the text file:
Bridge sonoff:account:balansventilatie “Sonoff Account” @ “myLocation”
[ email=“rene@.com", password="*”,accessmode=“mixed”]

Still cannot see my ‘thing’ and no binding. Search for ‘Sonoff’ gives nothing. Log file does not mention anything on Sonoff jar file.

Regarding this “still being worked on” binding I’d have a look into This Thread, others users repored the same problem ans seem to have resolved it.

Thank you all for the suggestions. I finally solved the problem I had. Didn’t find it in the suggested thread however but in an older thread on jar install in OH2 were someone suggested to do a ‘bundle:start’!!
Yes, and then my Ewlink account came up ‘online’ immediately! So I had everything done right including the things text file.
It is a pitty that in none of the instructions on using a jar file it is mentioned that one should do a ‘bundle:start org.openhab.binding.sonoff’.
Well working now as a charm.
Thank you

That’s because it should not be necessary to run that command. It could be something is wrong with the binding itself causing it not to be started automatically.


hello rene!

I’m running openhab 3, on an orangepi one, with Debian bullseye, everything works perfectly, but I have the same problem as you, when I download the org.openhab.binding.sonoff-3.2.0-SNAPSHOT_2.5R10.jar file to /usr/share/openhab/addons nothing happens.

I’m not a native English speaker, so it’s kind of confusing for me, including how I create the txt file with the ewelink credentials.

I couldn’t run that ‘bundle’ command you mention, maybe in debian it’s different.
Do you have a step-by-step link?

thnx! hug!

ok, I was able to find the openhab console on debian
<terminal$: ssh -p 8101 openhab@localhost >
<password: habopen>

but, it doesn’t recognize the command for sonoff file

openhab> bundle:start org.openhab.binding.sonoff
Error executing command: No matching bundles
openhab> bundle:start org.openhab.binding.sonoff
Error executing command: No matching bundles
openhab> bundle:start org.openhab.binding.sonoff
Error executing command: No matching bundles
openhab> bundle:start org.openhab.binding.sonoff-3.2.0-SNAPSHOT_2.5R10.jar
Error executing command: No matching bundles

maybe, I would paste the txt file with autentication first.

if u had the same problem i would appreciate the help.

it doesn’t appear even in bundle list

I’m certainly NOT an expert in openHab but I managed to get my sonoff devices working as described.
For the following it is assumed you have your sonoff devices working through the eWlink app on your phone.
As I understand from GitHub - delid4ve/openhab-3.x-sonoff: Openhab Binding for Sonoff Devices, you first have to create a ‘thing’ that acts as a bridge between your eWlink account and the sonoff devices. This is done by creating a text file named: sonoff.things
create this file in /etc/openhab/things/
the content of the file should look like this:
Bridge sonoff:account:balansventilatie “Sonoff Account” @ “myLocation”
[ email=“your_email”, password=“yourpassword”,accessmode=“mixed”]

replace “your_email” and “yourpassword” with the credaentials of your eWlink account.
replace the text “balansventilatie” (in Bridge sonoff.account.balansventilatie) for the name you prefer.
this name will show up in de openHab web interface under “things”.
If that is succesfull it will show green text with “ONLINE” and then your openHab has connected with eWlink.

then you can run in the openHab console:
openhab> bundle:start org.openhab.binding.sonoff

continue to check the log files in openHab console they give good information ( it gave me a hint when I had made a test error in the things file!)

When the Bridge thing shows up in the web interface you can continue to search for sonoff devices on your network.

1 Like

see my reaction on



1 Like

thanks for the step by step, and for your time, my friend!
I managed to create the file, thanx, but I still no success in the bundle

“openhab> bundle:start org.openhab.binding.sonoff
Error executing command: No matching bundles”

When I get it, I’ll update here.


as Hilbert specified above, the bundle:start should not be necessary as the binding should start automatically.
the only thing I found in other issue reports was the suggestion of Delid4ve to remove the Jar file and reinstall it new. It might be that you have to wait some time before the new installed file is processed in the background.(as I said I’m not an expert) Log files can give you some information if the file is correctly processed.
If you see it and is not working yet, wait a few minutes and you could try the bundle:start command.
I’m afraid this is all the help I can provide up to now.

1 Like

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.