Jasco/GE Smart Door Sensor not reporting to events

  • openHAB version: 2.5.1-2

  • Issue of the topic: please be detailed explaining your issue
    I’m brand new to openhab, transitioning from a SmartThings installation. I have added a Jasco Smart Door Sensor to my zwave things and it shows online in paperui. (This door sensor was previously working flawlessly with the SmartThings setup–it was properly excluded from the SmartThings hub before being factory resent and included in the openhab setup.)

I put the following confguration in a .items file.

Switch    FF_MasterBedroom_Closet       "Master Closet Door"       <door>          (FF_MasterBedroom, gDoor)     ["Door"]                           {channel="zwave:device:7027ae2c:node2:sensor_binary"}
Switch    FF_MasterBedroom_Closet_Alarm "Master Closet Door"       <door>          (FF_MasterBedroom, gDoor)     ["Door"]                           {channel="zwave:device:7027ae2c:node2:alarm_access"}

Nothing shows up in my log files when the sensor is tripped (i.e. the door is opened). The updates shown in the logs are me playing around with various aspects of the items file. After each change I opened/closed the door multiple times and the sensor confirmed it had activated with an audible click and its indicator light.

events.log:2020-01-28 19:32:55.549 [home.event.InboxAddedEvent] - Discovery Result with UID 'zwave:device:7027ae2c:node2' has been added.
events.log:2020-01-28 19:34:06.151 [me.event.InboxRemovedEvent] - Discovery Result with UID 'zwave:device:7027ae2c:node2' has been removed.
events.log:2020-01-28 19:34:06.203 [hingStatusInfoChangedEvent] - 'zwave:device:7027ae2c:node2' changed from UNINITIALIZED to INITIALIZING
events.log:2020-01-28 19:34:06.232 [hingStatusInfoChangedEvent] - 'zwave:device:7027ae2c:node2' changed from INITIALIZING to OFFLINE (BRIDGE_OFFLINE): Controller is offline
events.log:2020-01-28 19:34:06.244 [hingStatusInfoChangedEvent] - 'zwave:device:7027ae2c:node2' changed from OFFLINE (BRIDGE_OFFLINE): Controller is offline to UNINITIALIZED
events.log:2020-01-28 19:34:06.293 [hingStatusInfoChangedEvent] - 'zwave:device:7027ae2c:node2' changed from UNINITIALIZED to UNINITIALIZED (HANDLER_MISSING_ERROR)
events.log:2020-01-28 19:34:06.328 [hingStatusInfoChangedEvent] - 'zwave:device:7027ae2c:node2' changed from UNINITIALIZED (HANDLER_MISSING_ERROR) to INITIALIZING
events.log:2020-01-28 19:34:06.346 [hingStatusInfoChangedEvent] - 'zwave:device:7027ae2c:node2' changed from INITIALIZING to OFFLINE (BRIDGE_OFFLINE): Controller is offline
events.log:2020-01-28 19:34:06.351 [hingStatusInfoChangedEvent] - 'zwave:device:7027ae2c:node2' changed from OFFLINE (BRIDGE_OFFLINE): Controller is offline to ONLINE
events.log:2020-01-28 19:34:06.357 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:7027ae2c:node2' has been updated.
events.log:2020-01-28 19:34:06.363 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:7027ae2c:node2' has been updated.
events.log:2020-01-28 19:34:06.370 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:7027ae2c:node2' has been updated.
events.log:2020-01-28 19:34:06.378 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:7027ae2c:node2' has been updated.
events.log:2020-01-28 19:34:06.438 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:7027ae2c:node2' has been updated.
events.log:2020-01-28 19:34:06.441 [.ItemChannelLinkAddedEvent] - Link 'zwave_device_7027ae2c_node2_sensor_binary-zwave:device:7027ae2c:node2:sensor_binary' has been added.
events.log:2020-01-28 19:34:06.446 [.ItemChannelLinkAddedEvent] - Link 'zwave_device_7027ae2c_node2_alarm_access-zwave:device:7027ae2c:node2:alarm_access' has been added.
events.log:2020-01-28 19:34:06.455 [.ItemChannelLinkAddedEvent] - Link 'zwave_device_7027ae2c_node2_battery_level-zwave:device:7027ae2c:node2:battery-level' has been added.
events.log:2020-01-28 19:35:12.349 [.ItemChannelLinkAddedEvent] - Link 'FF_MasterBedroom_Closet-zwave:device:7027ae2c:node2:sensor_binary' has been added.
events.log:2020-01-28 19:39:02.749 [.ItemChannelLinkAddedEvent] - Link 'FF_MasterBedroom_Closet_Alarm-zwave:device:7027ae2c:node2:alarm_access' has been added.
events.log:2020-01-28 19:49:55.381 [temChannelLinkRemovedEvent] - Link 'FF_MasterBedroom_Closet => zwave:device:7027ae2c:node2:sensor_binary' has been removed.
events.log:2020-01-28 19:53:42.291 [.ItemChannelLinkAddedEvent] - Link 'FF_MasterBedroom_Closet-zwave:device:7027ae2c:node2:sensor_binary' has been added.
events.log:2020-01-28 20:04:20.045 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:7027ae2c:node2' has been updated.
openhab.log:2020-01-28 19:32:55.548 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing 'zwave:device:7027ae2c:node2' to inbox.


OpenHAB is flexible but cam be complex. You have not linked your Items to the Thing channel so the motion detector can change the Item state.

This post has an example. Zwave Items Format

Thanks. If you scroll to the far right of my original post, I have the channel, unless you’re saying I messed up the format of that?


I did more digging around and found that my /var/lib/openhab2/zwave directory has .xml files for nodes 1 and 3-5, but no node 2. (Node 2 is my door sensor.) I’ve removed and re-added the sensor several times and no .xml is ever created. I’m assuming this is the issue, but can’t figure out how to get that xml file. If it helps, habmin reports the sensor as

EDIT: that’s what the device is being discovered as. That’s not what the zwave database shows it should be (4953:3031) or (4953:3032) (zwave database for 2nd). I’m not sure which of these 2 very similar devices I have.

Manufacturer            0063 "Jasco Products"
Type / ID               4952:3036
Firmware Version        5.22


Sorry, I thought I scrolled right… :frowning:

The device had not been fully discovered then.

We show that as a wall switch! I do not remember Jasco reusing device ids before.

We need to do more research to see is our database is in error. In what world region are you located?
EDIT2: zwave alliance says our database is correct. @chris how do we handle this??

I’m in the US. I edited my original reply to you with the zwave database links for the actual device. The discovery is clearly wrong–but it’s happened that way every time I’ve excluded/included the sensor.

I edited my post above yours. The manufacturer data submitted to the Z-Wave alliance agrees with our database.

Both those devices start with 4953. Perhaps you have a defective device? I have not seen one misidentify like that.

We have the second one in our database.

Thanks for the quick assistance. Now, I’ve come to the conclusion that the discovery is being done incorrectly.

This door sensor in your database is what I believe it should be.

My question changes then to be how do I force a change in the discovery or recognition of a device to match what it should be?

1 Like

I tagged Chris a few posts back. Let’s wait for his determination. He is the developer and an expert.

Thanks so much @Bruce_Osborne , there’s a steep learning curve on openhab! As far as the possibility that it is a defective device, it’s functioned 100% as expected under SmartThings for the last ~18 months. I think it’s more the discovery/device identification in openhab.

OK. Again @chris can advise

Do I understand that there is no XML being created still, or is this resolved? If there’s no XML, then the system is not working and the device is not completing initialisation. Until this is resolved, the database is irrelevant.

@chris there is still no XML being created.

I have excluded/included the device at least 5 times, with a factory reset (10 button pushes within 6 seconds, confirmed by the device’s blinking light) each time.

Is there a way to babysit the device through initialization or debug where it’s breaking down?

I have excluded/included again and this time the device type/ID is correct, but still no xml being created.

Battery powered devices need to be woken up many times to be completely discovered by OH. I have sometimes deleted and re-discovered the Thing to trigger a new discovery. Exclusion and Inclusion from the network is not needed and may create zombie nodes.

As Bruce said - the device will need to be woken up. There will normally be a button to do this - or a sequence of presses on a tamper switch or something like that. This should be described in the manual.

1 Like

@adkisson This is what we have in the database about waking that device up.

1. Press and hold the Z-wave Button for 6 seconds. It will be wake up and send “Wake Up Notification CC “ to HUB. 
2. It will sleep after timeout for 10 seconds, or sleep right away when received the “Wake Up No More Information CC”. 


I have deleted and discovered multiple times while obsessively keeping the device awake (holding the button every time the blinking green light stopped). I did this several times before turning on debugging (output of debug attached)debug.txt (282.7 KB) . I’ve tried initiating a device heal, but that doesn’t work.

NODE 2: Can not start heal as initialisation is not complete (VERSION).

Still no xml file.

Perhaps check with Jasco support? The documentation is not always correct.
I had one battery powered sensor where a button press was supposed to wake it up. I found I needed to press 3 times for OH to see it was awake. Apparently a frustrating documentation error.

Update: I have 3 of these sensors. 1 works great. 1 only reports the battery % but no alarm or switch. The last one doesn’t do anything. The first 2 had xml files generated. The last one never has gotten one. All 3 were associated with the zwave in the exact same way.