Java Error-Runtime Stop

Openhab 2 runing on Raspberry Pi 2, but any time

A fatal error has been detected by the Java Runtime Environment:

SIGSEGV (0xb) at pc=0x766aa5e0, pid=2362, tid=1591399536

JRE version: Java™ SE Runtime Environment (8.0-b132) (build 1.8.0-b132)
Java VM: Java HotSpot™ Client VM (25.0-b70 mixed mode linux-arm )
Problematic frame:
V [] InstanceKlass::find_method_index(Array<Method*>, Symbol, Symbol*)+0x38

Failed to write core dump. Core dumps have been disabled. To enable core dumping, try “ulimit -c unlimited” before starting Java again

  • Raspberry Pi2 _ 2015-05-05-raspbian-wheezy
  • Openhab_ distribution-2.0.0-SNAPSHOT-runtime (#354)_ and _openhab-2.0.0.alpha2-runtime
  • java version “1.8.0”
    Java™ SE Runtime Environment (build 1.8.0-b132)
    Java HotSpot™ Client VM (build 25.0-b70, mixed mode)
  • Install manuel Path_ /opt/openhab
  • startup run prompt for “”_ /etc/rc.local

Average data usage.

Is there a need to do more? or is there wrong? Could it be the Rule, Items or Sitemap? Thanks.

I don’t know what causes it but I get a similar error on my Raspberry Pi2 every couple of days so I’ll watch this thread.

My is working 3-15 hours. I’ve been trying for days but could not find a solution. :frowning:

The above page autostart for the specified “DAEMON_ARGS” entry pivotal sturdy? Is it possible to do with it?

Usually, when a SIGSEGV occurs there is nothing wrong with your setup or with the code of openHAB, but it is simply a bug in the JVM that it runs into. It is hence hard to tell, what exactly causes it and how you could workaround it. You could report it to Oracle and hope that it is fixed in a future update of the JDK…
What might help is to downgrade to Java 7, maybe this does not have this bug.

java7 also have the same problem. Now I’m following procedure on the links below.

The specified note.
By default, swapping is disabled in Debian Linux. If an operation exceeds the Raspberry Pi’s 256KB RAM size, the system crashes."