Java Issue

I have this error : " Failed to write core dump. Core dumps have been disabled. To enable core dumping, try “ulimit -c unlimited” before starting Java again " I use raspberry pi platform. Please help me

Are you using Oracle Java or OpenJava?


I am using oracle java and versin is below.

pi@raspberrypi ~ $ java -version
java version "1.8.0"
Java™ SE Runtime Environment (build 1.8.0-b132)
Java HotSpot™ Client VM (build 25.0-b70, mixed mode)

A core dump means something massively fundamental is going wrong with the underlying hardware or the JVM. I’m not sure the problem is caused by OH or anything that OH can do. I’ve been programming Java for over a decade and I can’t remember a single case where Java core dumped where the real problem wasn’t hardware or OS level.

Try reloading the SD card and raspbian from scratch and see if that makes the error go away. If it persists I would suspect your Pi has bad RAM or something like that.

I reported the problem to oracle support team. The team said the problem solved with oracle jdk-9 . While openhab ran with jdk-8 I installed jdk-9 but openhab didnt run with jdk-9. Please help me

What error did you get? The same error?

Not same issue. Openhab didnd open.

Usually there is something logged out somewhere with an error of some sort. It is exceptionally rare that it doesn’t open AND doesn’t generate something telling you why.

Check openhab.cfg, syslog, and sysctrl status to see what it might be saying when it fails to come up.

Can openhab 1.8.3 be inconpetible with jdk-9 ?

I doubt it. But ever if there were I would expect to see something in the logs or printed out when OH starts.

I’m running with Oracle 1.8.0_77 though so don’t know for sure.

when I executed ./ I didnt see anything on console.