Java's sound sink

So I am running OH2 on my pi3.
I also have google home assistant running on said pi.

Audio capture and playback is done via a USB speaker/microphone thingy.
I modified the alsa config file to default to the USB card instead of the onboard chips.
speaker-test and aplay all play sound to my USB device as expected.

OH does not seem to want to output sound.
I tried openhab> smarthome:audio play doorbell.mp3 in karaf without success.

Anyone got any ideas how to debug this one?

My thinking is that the problem lies somewhere in ALSA.
Because there are so many modes in ALSA that could be configured… maybe I missed to point one of them to the USB?

So… how does Javasound work? plughw? sysdefault?

I got OH using my default ALSA device (echo dot over Bluetooth) by adding the openhab user to the audio group and adding the following to /usr/lib/jvm/zulu-embedded-8-armhf/jre/lib/

My problem seems to be asla.
After messing about, speaker-test and some other apps like Google home
assistant no longer worked but suddenly Java sound did…

Openhab is part of the group…

What do these lines do? They seem relevant.
Where do they go?