Jetty Client - help needed

Hello, I’m requesting help here because I’m completely stuck in finding a solution to address this issue..

The error raised on

final String jsonResponse = HttpUtil.executeUrl("GET", url, httpHeader, null, JSON_CONTENT_TYPE,

is java.util.concurrent.ExecutionException: HttpConnectionOverHTTP@2a6b902b::DecryptedEndPoint@68b02aa{<->/,OPEN,fill=-,flush=-,to=59/0}

All my searches on the web finished nowhere and there is no evidence of what generates the exception. Despite all my attempts to circumvent, I’m in a dead end.

I tried to exclude TLSv1.3 that seems pointed in relation with JVM 11.
I tried to provide the SSL certificate.

In my production environment (OH v2.5.7), it works but users on v2.5.9 reported the error, and I’m working on v3.0 in dev.

Would somebody have an idea ?

A bit of light at the end of the pipe : using instead of jetty http client seems to work.
Is this a valid option for v3.0 development ? This would not solve issue for v2.9.x…

AFAIK we should use httpClientFactory instead of HttpClient directly.

That’s what is used through HttpUtil.executeUrl

I think you should use HttpClient instead of HttpUtil.You could see how I use it in Intesis binding.

I did it, same result. It really seems to be located in Jetty.

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.