Jetty Timeout issues, looking for suggestions on a fresh rebuild

I’ve been running openhab via openhabian for a few years happily on this hardware rpi 2.
In the last week or so I started experiencing issues accessing the Web interface, logs showed a few broken items, I hadn’t removed the yahoo weather stuff for example. The other entry seems to time outs for jetty.
I’ve backed up and removed all items, things and site maps, same thing.

I’ve now flashed a fresh copy openhabian v1. 5 to the card and I’m still seeing this issue before I’ve started to add things.

All updates are applied, it’s a fresh unmodifed image, can anyone confirm if there are issues in the pipeline with some dependancy?

Searching for the error there was a suggestion the timeout default changed a year or so ago and could be overridden, but I’m surprised this is the case. There was also a suggestion a typo in a config file could cause this, but I’m now running with no customisations.

I guess it could be hardware issue, I may borrow a pi3 and try in that. Could it me a sd card issue, I’ve had them die before but usually the system doesn’t boot as result. I plan to move the root to my nfs server once it’s working again.

Any other suggestion would be welcome.


I would certainly try another sd card just to confirm and or rule that issue out. Never hurts to have an extra card around anyway.

Of all things I would suspect the card first before other hardware.

1 Like

Thanks, but still not working. I’ve used a different sd card tonight, it installs fine as before, going to http://openhab:8080/
I get ��� 3 ? in diamonds and it produces this in the log
openhab-cli showlogs

==> /var/log/openhab2/audit.log <==

==> /var/log/openhab2/events.log <==

==> /var/log/openhab2/openhab.log <==
Caused by: java.util.concurrent.TimeoutException: Idle timeout expired: 30000/30000 ms
at ~[?:?]
at$ ~[?:?]
at java.util.concurrent.Executors$ ~[?:?]
at ~[?:?]
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201( ~[?:?]
at java.util.concurrent.ScheduledThreadPoolExecutor$ ~[?:?]
at java.util.concurrent.ThreadPoolExecutor.runWorker( ~[?:?]
at java.util.concurrent.ThreadPoolExecutor$ ~[?:?]
… 1 more

Steps to recreate, flash openhabian 1.5 from site to a 16Gb card, tonight I’m using a 32Gb card.
insert into RPI 2 B
boot and wait
after 20-30 minutes log in via console
run setup, install option component mosquitto, set password, update

visit openhab:8080/

if it loads select standard

==> /var/log/openhab2/events.log <==
2019-10-07 22:05:25.564 [thome.event.ExtensionEvent] - Extension ‘package-standard’ has been installed.

==> /var/log/openhab2/openhab.log <==
2019-10-07 22:05:44.046 [WARN ] [org.eclipse.jetty.server.HttpChannel] - /start/css/bootstrap.min.css
javax.servlet.ServletException: java.util.concurrent.TimeoutException: Idle timeout expired: 30000/30000 ms
at org.ops4j.pax.web.service.jetty.internal.JettyServerHandlerCollection.handle( ~[?:?]
<…SNIP …>
2019-10-07 22:05:52.715 [INFO ] [arthome.ui.paper.internal.PaperUIApp] - Started Paper UI at /paperui

==> /var/log/openhab2/events.log <==
2019-10-07 22:05:52.823 [thome.event.ExtensionEvent] - Extension ‘ui-homebuilder’ has been installed.
2019-10-07 22:05:52.831 [thome.event.ExtensionEvent] - Extension ‘ui-basic’ has been installed.
2019-10-07 22:05:52.838 [thome.event.ExtensionEvent] - Extension ‘ui-habpanel’ has been installed.
2019-10-07 22:05:52.843 [thome.event.ExtensionEvent] - Extension ‘ui-paper’ has been installed.

however the webpage doesn’t move on and reloading the page and I’m back to the diamonds.

maybe its up stream or am i just using a bad combination of the very latest updates to the packages.

I also put the card in a pi 3 and it was equally stuck. I’m going to revert to an earlier openhabian image and see if that works.

It shouldn’t be a HW issue, don’t bother trying.
But you fail to properly explain what you did:
what OH version (not openHABian but openHAB) did you install?
Does it happen right after a fresh install or only after you configured or imported anything?
how do you copy over/import your config ?
What browser and language do you use to access the page ? Tried a different one ?
I’d either way suggest to go with the ‘expert’ mode not standard.

Hi sorry for the lack of clarity.

I’m using the openhabian 1.5 image from the site, will have a look later to see what versions are actually now on my pi.

At the moment I’ve not copied anything over the problem seems to ocurrs straight after the first boot.

I’ve tried chromium and Firefox from my Linux laptop and chrome from a android mobile. Probably also tried accessing from Windows too.

In terms of language, that’s a thought I’ve not been prompted to set that during the initial setup.

I can probably bring it into work tomorrow and try the first boot via a different ISP. Just incase some cache is corrupted upstream.

You still didn’t answer what OH version you run.

Try flashing openHABian again. If you just boot it after that, it should come up with that page working.
If not you should be seeing errors during install (stored in /boot/first-boot.log).
This can happen e.g. if your router isn’t properly providing DNS and DHCP.

Another fresh install this time selecting an older image of openhabian 1.4 this installs OH is Version: 2.4.0 (Build)

Webpage fails to load

I can’t see anything wrong here

2018-03-13_22:53:41_UTC [openHABian] Starting the openHABian initial setup.
2018-03-13_22:53:41_UTC [openHABian] Storing configuration… OK
2018-03-13_22:53:41_UTC [openHABian] Changing default username and password… OK
2018-03-13_22:53:42_UTC [openHABian] Setting up Ethernet connection… OK
2018-03-13_22:53:42_UTC [openHABian] Ensuring network connectivity… OK
2018-03-13_22:53:42_UTC [openHABian] Waiting for dpkg/apt to get ready… OK
2019-10-08_19:03:28_UTC [openHABian] Updating repositories and upgrading installed packages… OK
2019-10-08_19:13:44_UTC [openHABian] Installing git package… OK
2019-10-08_19:14:39_UTC [openHABian] Cloning myself… OK
2019-10-08_19:14:42_UTC [openHABian] Executing ‘ unattended’…
2019-10-08_19:14:43_UTC [openHABian] Checking for root privileges… OK
Hit:1 stretch InRelease
Hit:2 stretch InRelease
Reading package lists…
2019-10-08_19:14:57_UTC [openHABian] Loading configuration file ‘/etc/openhabian.conf’… OK
2019-10-08_19:14:57_UTC [openHABian] Setting timezone based on IP geolocation… OK (Europe/London)
2019-10-08_20:16:53_BST [openHABian] Setting locale based on openhabian.conf… OK
2019-10-08_20:17:39_BST [openHABian] Setting hostname of the base system… OK
2019-10-08_20:17:39_BST [openHABian] Setting the GPU memory split down to 16MB for headless system… OK
2019-10-08_20:17:40_BST [openHABian] Enabling Audio output… OK
2019-10-08_20:17:40_BST [openHABian] Installing basic can’t-be-wrong packages (screen, vim, …)… OK
2019-10-08_20:18:55_BST [openHABian] Installing additional needed packages… OK
2019-10-08_20:19:38_BST [openHABian] Adding slightly tuned bash config files to system… OK
2019-10-08_20:19:38_BST [openHABian] Adding slightly tuned vim config file to system… OK
2019-10-08_20:19:38_BST [openHABian] Downloading and setting up FireMotD… OK
2019-10-08_20:21:08_BST [openHABian] Installing Java Zulu 32-Bit OpenJDK… OK
2019-10-08_20:22:32_BST [openHABian] Installing or upgrading to latest openHAB release (stable)… OK
2019-10-08_20:23:42_BST [openHABian] Adding an openHAB dashboard tile for ‘openhabiandocs’… OK
2019-10-08_20:23:42_BST [openHABian] Adding openHAB syntax to vim editor… OK
2019-10-08_20:23:43_BST [openHABian] Adding openHAB syntax to nano editor… OK
2019-10-08_20:23:44_BST [openHABian] Adding openHAB scheme to multitail… OK
2019-10-08_20:23:44_BST [openHABian] Preparing openHAB folder mounts under /srv/… OK
2019-10-08_20:23:44_BST [openHABian] Applying file permissions recommendations… OK
2019-10-08_20:23:49_BST [openHABian] Applying miscellaneous system settings… OK
2019-10-08_20:23:50_BST [openHABian] Setting up Samba network shares… OK
2019-10-08_20:25:01_BST [openHABian] Installing Node.js for arm (prerequisite for other packages)… OK
2019-10-08_20:25:13_BST [openHABian] Installing the openHAB Log Viewer (frontail)… OK
2019-10-08_20:27:19_BST [openHABian] Adding an openHAB dashboard tile for ‘frontail’… OK
2019-10-08_20:27:20_BST [openHABian] Execution of ‘ unattended’ completed.
2019-10-08_20:27:20_BST [openHABian] Waiting for openHAB to become ready… OK
2019-10-08_20:28:37_BST [openHABian] Visit the openHAB dashboard now: http://openHABianPi:8080
2019-10-08_20:28:37_BST [openHABian] To gain access to a console, simply reconnect.
2019-10-08_20:28:37_BST [openHABian] First time setup successfully finished.

visit the webpage - waiting

check the logs
openhab-cli showlogs

==> /var/log/openhab2/audit.log <==

==> /var/log/openhab2/events.log <==

==> /var/log/openhab2/openhab.log <==
Caused by: java.util.concurrent.TimeoutException: Idle timeout expired: 30000/30000 ms
at ~[?:?]
at$ ~[?:?]
at java.util.concurrent.Executors$ ~[?:?]
at ~[?:?]
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201( ~[?:?]
at java.util.concurrent.ScheduledThreadPoolExecutor$ ~[?:?]
at java.util.concurrent.ThreadPoolExecutor.runWorker( ~[?:?]
at java.util.concurrent.ThreadPoolExecutor$ ~[?:?]
… 1 more

  1. use code fences.
    How to ask a good question / Help Us Help You

  2. you didn’t answer my question on prerequisites (DNS, DHCP)

  3. try 2.5M1 (testing in openHABian menu)

  4. reinstall using OH 1.5 image
    edit /opt/openhabian/build-image/ around line 161 (the line with openhabian-setup being called) and add “unattended_debug” as an argument to openhabian-setup

  5. open a Github issue
    don’t shorten the logs! Your excerpt is meaningless.

OK thanks, I’ll try when I get home later. I’m sure my dns/dhcp are working no other devices have issues and the box hasn’t change since I installed this originally a year or two ago.

Would be nice to know if openhabian 1.5 installs correctly for others at the moment to ensure its not something in the updates that get installed as part of the process.

Yes it does so there must be something specific about your install we need to identify.

Hi Markus,

I’ve seen your Debugging instructions issue post on github, I think that will be helpful.

I’m assuming I have boot once and catch it mid boot to change the /opt/openhabian/build-image/ Looking at a freshly etched image, the opt folder only contains a vc folder and an “openHABian-install-inprogress” file before this card has been in the pi.

or do you mean the first-boot.bash file in the boot partition?

yes that’s the one that is executed

Thanks for your help.

I’ve restored my pi to and image from April when it was working. Unfortunately the Web interface is still unreliable, It was fine when i took the backup of the card. At least now the connection via Google home and Alexa is working, the family can turn thing on and off with that.

I’ve also tried using etching the image using another pc to another sd card, putting thst in a different pi with a different powersupply connected to a different fttc Internet connection and router. My conclusion is either something is broken in the image or first run scripts.