Joining as a secondary controller

zwave
Tags: #<Tag:0x00007f51e4743730>

(Jörg) #1

Dear all,

in the manual for the zwave-binding I can find this infomrtion:

Joining as a secondary controller
The binding can be added to the network as a secondary controller. This can be useful if you already have another home automation system and you want to use the binding as a secondary controller…

But there is not discribed how this can be done out of the “Configuration > Things > Razberry - Z-Wave Serial Controller”

How can the razberry-zwave-device set in to learn mode so that the device can join as scondary controler

Kind Regards
Jörg


(Chris Jackson) #2

There can only be a single primary controller in a network, so if you join another controller it will be a secondary controller.

There are a lot of limitations with this so don’t expect to have all the features you get as a primary controller such as being able to control battery devices or getting lifeline notifications…


Strange forum and stupid user (me)
(Jörg) #3

Dear Chirs,

thank you for your fast response to my question. I’m aware of this limitations, the raberry-device is allready include in my zwave-network as secondary controler what I managed to do by set the razberry-zwave-device in learn-mode by a sepparate z-way-installtion on my raspberry-Pi. To make new other zwave-devices know by the secondary controler (razberry-device) I have to set the secondary controler (razberry) allways to learn-mode by booting the zway-resperry-installation. This I want to avoid by making use of the “Joining as a secondary controller” and set the secondary controler to learn-mode via zwave-thing of openhab2 so that I do not have to switch between openhab2-raspberry-installation and zway-raspberry-insatllation.

Is there an option to do so?

Kind Regards
jörg


(Chris Jackson) #4

Hi Jorg,

I’m not sure I follow. Do you mean that the razberry is permently in learn mode? If so, I guess you somehow need to disable this in the razberry right?

You can’t directly control the learn mode of another controller. You should just be able to use learn mode in OH2 and ignore the primary controller. The primary should be set as the SIS and therefore should be updated when a new device is added.

What is probably not implemented is network updates in OH2 if you add devices through the primary as I’ve not added network replication functions.


(Jörg) #5

no, no razberry will only be set to learn-mode by myself (via zway software by booting a specal raspberry instalaltion) if I want to make a new zwave-device know to secondary controler (razberry) which had be added to before to the primary controler. The razberry learns all the device which are know by primary controler. This works quite well, but to do that I have to shutdown openhab put SD-Card with zway-distribution and reboot, set razberry to learn mode, new devices from primary controler are learnt, put razberry to normal mode again, remove the SD-Card with zway-distribution, put openhab-SD-Card in raspberry and boot. Now I can handle the new learnt devices also in openhab, perfect.

But! I would like to set razberry into learn mode directly form openhab2-zwave-binding, this would be greate and would allow a much easier and more efficient handling of razberry as secondere controler without rebooting a zway-installation from a seperat SD-Card.

hope you could follow my thoughts.

sorry that I was not precise engouh in my frist explaination

Kind Regards
Jörg


(Chris Jackson) #6

The whole issue is not so simple…

Within a ZWave network, there are primary and secondary controllers, but also a Static Inclusion Server (or Static Update Controller). One of the controllers should be the SIS - this controller should be advised of any new inclusions automatically and it is the entity that produces the node id.

So, you should be able to include devices via any controller, and the SIS should provide the node ID. Other controllers in the network should then find out about updates to the network via a controller replication feature (which is not currently implemented in OH). This means that in theory all controllers know the network topology, and you don’t need to control inclusion with any specific controller.

I think at the moment, you are thinking that in order to include a device, you need to enable inclusion with the primary controller, but this isn’t correct. Probably the primary controller (ie razberry) is the SIS, and it should therefore be the one allocating the node ID.


OH2 Z-Wave refactoring and testing... and SECURITY
(Jörg) #7

Dear Chris,

thank you very much for your details explaination. I was not aware of that beside primary and secondary controlers also an Static Inculsion Server resp. Static Update Controler is in the Network. However my razberry is a secondary controler and I have to leave this as it is. I have taken a look to the settings in Paper UI of the zwave-Binding and it is set to SUC (Satic Upload Controler). Nevertheless the razberry (in my case the secondary controler in the zwave-network) does not gets updates of new devices from the primary controler. This only work if I set the razberry to learn-mode, which I can’t do within openhab-zwave-binding as already explained, for doing this I have to reboot with the zway-distribution.

mmhhhh strange isn’t it?

Kind Regards
Jörg