Jsonpath not installed and not shown in available addons

  • Platform information:
    • Hardware: VM, 2 Cores, 4GB RAM, 100GB Disc
    • OS: Debian 10
    • Java 11.0.20
    • openHAB version: 3.4.4
  • Issue of the topic: jsonpath not installed and not shown in Addons

i have problems installing jsonpath because it isn’t shown in Addons.
I already tried installing it automatically via addons.cfg setting “tranformation = jsonpath”.
In the UI i activated marketplace addons but the “other addons”-page stays empty

As your system is a bit out-of-date… did you setup correct repository?
i.e. in /etc/apt/sources.list.d/openhab.list the line

deb [signed-by=/usr/share/keyrings/openhab.gpg] https://openhab.jfrog.io/artifactory/openhab-linuxpkg stable main

and don’t forget to install the current (brand new) pubkey…

wget -qO- https://openhab.jfrog.io/artifactory/api/gpg/key/public | gpg --dearmor | sudo tee /usr/share/keyrings/openhab.gpg >/dev/null
1 Like

Thank you for your reply. I just found the problem.
Cleaning the cache solved the problem.

But i will also check for the correct repo later on, thank you!