Jupnp & upnp Manual Upgrade v2.3 to 2.5

Is it possible to upgrade my v2.3 org.jupnp binding manually to v2.5 by dropping in the JAR?

I have v2.3 jupnp running and I’d like to install v2.5 jupnp but when I tried; both got installed even though I uninstalled v2.3 via Karaf. Is this part of the core which I can’t upgrade w/o upgrading the core? Do I disable v2.3 from loading in some sort of config file?

I have the v2.5 upnp transport and discovery bindings in place and active.

Here’s what I got now:

171 â Active    â  80 â 2.3.0                  â org.jupnp
200 â Active    â  80 â 0.11.0.oh250M1         â org.eclipse.smarthome.io.transport.upnp
208 â Active    â  80 â 0.11.0.oh250M1         â org.eclipse.smarthome.config.discovery.upnp

Best, Jay

@jwiseman

From your bundle:list I can see that you have installed the 2.5.0.M1 (transport.upnp and discovery.upnp).

I’m not sure, but there are more possibilities:

jupnp 2.5.2: (Feb 22, 2019 = after 2.5.0.M1 release)

bundle:install https://dl.bintray.com/jupnp/mvn/org/jupnp/org.jupnp/2.5.2/org.jupnp-2.5.2.jar

or

jupnp 2.5.1: (Dec 14, 2018, =before 2.5.0.M1 release)

bundle:install https://dl.bintray.com/jupnp/mvn/org/jupnp/org.jupnp/2.5.1/org.jupnp-2.5.1.jar

or

jupnp 2.5.0: (Dec 03, 2018)

bundle:install https://dl.bintray.com/jupnp/mvn/org/jupnp/org.jupnp/2.5.0/org.jupnp-2.5.0.jar

.
.
I would try the 2.5.1.
.

Btw: In latest “Openhab 2.5.0 Release”, org.jupnp-2.5.2.jar is used.

I actually dropped 2.5.2 version into the Addon’s. The issue I was having from this original thread was when I cleared cache/tmp that 2.5.1 got pulled back into the mix even though I had 2.5.2 dropped in the Addon’s. I have just learned to uninstall 2.5.1 when I clean cache/tmp and start OH back up.

The real issue around upgrading jupnp is the issue with Sonos speakers falling into “communication-error” status and they can NOT recover from it. The only thing that fixes it is a clean start of OH (which can last 1 - 2 days before it happens again) or some folks have even created a script to stop/start jupnp while OH is running via a rule.

I would assist anybody who would take on fixing the jupnp issue with Sonos.

Best, Jay

https://www.bountysource.com/issues/80365719-jupnp-failing-causing-devices-to-go-offline

Best, Jay

Dear Jay,

I’m having the same issue with going SONOS offline after a while. I also understood that it might have something to do with the SamsungTV binding. Am I write assuming installing the JUPnP Library in version 2.6?

Thanks for your help!

Hey Fabian,

If you have the v2.5 Samsung binding along with the Sonos binding - then there is many different issues going on right now with them.

Here’s a post about it that is very active in trying to debug the issues in both bindings including the JUPnP binding.

JUPnp & Samsung - https://github.com/openhab/openhab-addons/issues/5892#issuecomment-619600728

Sonos - https://github.com/openhab/openhab-addons/pull/7445

I would recommend you downgrading your Samsung TV binding to v2.4 until all of this is fixed. My system has been pretty rock solid with Samsung TV binding v2.4, JUPnP binding v2.5, and Sonos Binding v2.5. I understand that the Samsung TV v2.4 binding doesn’t support as many TV’s as the 2.5 does but it does resolve the stabilization issue of OH.

Best, Jay

[quote=“jwiseman, post:6, topic:69835”]
I would recommend you downgrading your Samsung TV binding to v2.4 until all of this is fixed. My system has been pretty rock solid with Samsung TV binding v2.4, JUPnP binding v2.5, and Sonos Binding v2.5.[/quote]
It really looks like this did the trick. It even seems that the system is more stable in general, e.g. my Netatmo provides reliable measurements again. Thank you very much, it’s much appreciated!

Found this thread after my 2 sonos devices go offline now and then. I also have a the Samsung binding v2.5.8
Recently I also installed the Nuki binding, and I feel there are some upnp issues with it as well. not sure if that binding could be interfering also.

For the moment I turned off hueemulation service, as it seemed the upnp conflict with Nuki was hueemulation related.

anywhoo, will try disabling the samsung binding for the moment (or revert to 2.4) and see how everything functions.
cheers
phil