Just transferred from Windows to Openhabian on a pi. Rules aren't working now

  • Platform information:
    • Hardware: Raspberry Pi 3b+ 128GB SSD using Aeotek Z-wave USB
    • OS:Openhabian, latest Build
    • Java Runtime Environment:
    • openHAB version: 2.5.10

I just built a new Openhabian install with the latest build etc. Configured all my basic items and rules which worked on the windows PC but now the rules are not working. Very basic stuff, at XX:00 PM turn on Lights “A, B, C etc” and then turn them off at x time. If I run the rules manually they work fine but they are not being triggered by the time of day for some reason. Checked the system time etc and all is well. What stupid little basic idiotic thing am I missing? LOL

How are you running them manually? Do you mean there is a trigger for an Item change and it will trigger when toggling the Item? Or do you mean rules created in the UI rule editor?

Assuming your rules are logging something when they are running, how long have you monitored the log files? Meaning, is this something new, or has it been happening for days? Look at the timestamps in your log and compare to the time at a console prompt. Do they look like they are in the same timezone… and they match your timezone?

I was right, that stupid little basic idiotic thing I was missing? SET THE(&@#&( TIME…UGH…This is what happens when I get to work from home and try to do many things including work… Thanks guys! Cannot believe I missed that…Sigh

OK I was wrong I am still having issues where items just turn on when they want, off when they want. Turn back on after I turn them off…Didn’t have this problem with windows at all it was rock solid. I am going to remove all the things, verify all settings then re-add everything. If it happens again I will be deep diving the logs… yay.