Known issues on OH3 upgrade

Well I only have a peek at posts so can easily be mistaken when taking the decision to move a post.
A custom port in the first place IMHO is a custom problem. I don’t think many users change it.

1 Like

A post was split to a new topic: Upgrade issue

HABPanelViewer: OH3 changed REST event topics (not mentioned as breaking change), thus HABPanelViewer Command Item is broken. For now use 0.9.27pre linked in first post of HABPanelViewer thread until an official release is available.

A post was split to a new topic: OH3 persistence freeze

A post was split to a new topic: Upgrade issues with Samba et al

A post was split to a new topic: Cors problem

Hi Markus,
I noticed that in the breaking changes it’s missing the fact that this API will no longer be working. I know it’s not an official API, but many users rely on this API for their setups, so I think everyone should know it:


I have opened my own topic on the subject, as a workaround should be provided:


This is no breaking change as it never was officially supported.
Further answer in your topic.

Just a small hint for further changes in Rule:
With OH2.5
Integer::parseInt(<A String for example with sql result>)
worked fine, equal the result has a carriage return or a line feed in.

With OH3.0 you need to eliminate CR and LF for example with Split:

Integer::parseInt(<A String for example with sql result>.split('\n|\r|\\n\r').get(0))

Otherwise parseInt get the numeric-value with an CR or LF at the end.

just replace classicui by basicui.
still working fine.

As far as I can work out system started trigger does not trigger if a (DSL?) .rules file is modified. See also:

1 Like

Hey Markus,
i mentioned one issue before in this thread and it was moved. i did a little research and maybe it does effect a bunch of people. please take 2minutes to trie it out. i did a description of the problem in the old post.

Thanks for your awesome work.

For me rp4 on openhabian. The branch is always jumping back to OH2 stable. I tried downgrade and upgrade again. If I change /etc/openhabian.conf clonebranch to openHAB3 it always shows the update dialog of openhabian in the beginning and partly stays on the correct branch untill I try to run any scripts like update or install fonttail. Diddn´t had time to investigate deeper, but will now go back to OH2 since already just the update doesn´t to work correctly.

The update from Openhab 3.0.1 to Openhab 3.1.0 on Raspi with the updatescript on …/bin/update fails with error 404- file to download not found. Also …/update 3.1.0 fails with the same error.
So I’d download the complete installation zip from the website and replace the updatescript on …/bin/ with the file from the ziparchive and run …/update 3.1.0 - it work.

Might have needed to go via 3.0.2 to account for remote repository relocation

Not sure if the background of

is fully understood.
But using the update script in runtime/bin for older versions than 3.0.2 also would have not worked as it contains a download link to the old bintray folder structure.
What would have helped here would have been to use the apt install/update method after changing the repo location of bintray as it is a raspi installation - this seems to be what you meant - not sure if this is clear for @agricola.

It’s all right, my update is done.
I would show the way to update directly from version 3.0.1 to 3.1.0 without the step 3.0.2.
If you think this is the wrong task for my post please feel free to move or delete it…

For info, Copy of breaking changes can be found here:


That link with the breaking changes is a dead end. Where can I find it?

I suppose you could try the post immediately preceding yours.