Known issues w/ habpanel not saving custom widgets?

As part of some time off during the holidays, finally cracked open OpenHab and trying to evaluate HabPanel vs HABmin.

I like the ability for HabPanel to have custom widgets, but when I try and save any custom widgets on a form, the form saves with any non-custom widget changes, but no custom widgets.

I am using a 100% virgin version of the latest demo install from the web site, not any more recent builds.

Can I get some help trying to figure out what is wrong?

This is weird, can you give more details (like hit F12 on Chrome and check for any errors in the Console and Network tabs)?

Here are some details, hope they help.

In the console window, tailing the log, and when I save the panel (or when I added a new blank custom control), I saw:
22:22:18.825 [INFO ] [panel.internal.HABPanelDashboardTile] - Stopped HABPanel
22:22:18.860 [INFO ] [panel.internal.HABPanelDashboardTile] - Started HABPanel a
t /habpanel

In this case, I am importing the weather control, and in the cases where I added the default control and saw 2 lines like this appear in the logs, they didn’t appear.

Hitting F12 in Chrome, when I press the save button, I don’t see anything in the logs, but in the console window:
openHAB 2 service configuration loaded
vendor.js:119 URIError: URI malformed
at decodeURI ()
at XMLHttpRequest.send (xhrExtension.js:2)
at vendor.js:105
at n (vendor.js:100)
at vendor.js:98
at vendor.js:132
at m.$eval (vendor.js:147)
at m.$digest (vendor.js:144)
at m.$apply (vendor.js:147)
at l (vendor.js:99)
(anonymous) @ vendor.js:119
(anonymous) @ vendor.js:92
(anonymous) @ vendor.js:133
$eval @ vendor.js:147
$digest @ vendor.js:144
$apply @ vendor.js:147
l @ vendor.js:99
K @ vendor.js:103
N.onload @ vendor.js:104
openhab.service.js:332 Error while saving openHAB 2 service configuration: {}
(anonymous) @ openhab.service.js:332
(anonymous) @ vendor.js:132
$eval @ vendor.js:147
$digest @ vendor.js:144
$apply @ vendor.js:147
l @ vendor.js:99
K @ vendor.js:103
N.onload @ vendor.js:104
persistence.service.js:110 Error while saving to openHAB 2 configuration

Also, in case you ask for the main installed version:

199 | Active | 80 | | HABPanel User Interface

Does this help?

You seem to have the same problem as @Mike_Bagdanoff here: % and custom widgets

So there’s definitely an issue, I just don’t seem to be able to reproduce it. Maybe you have the ‘%’ problem too? I’ll try the weather widget as well.

Since I can reproduce it here, is there any other information I can dig up for you on this? Note that I am an SDET IRL, so digging into issues like this is not a problem and actually is in my wheelhouse.


  • would trying other custom widgets help in narrowing down where the issue is?
  • is there some way I can try removing the % to see if that is the issue?

Found this Jupyter issue after a quick Google search:

Do you happen to have LastPass installed?

Yup, use it all the time to make sure I have more secure passwords.

And… that worked like a charm. Do you want me to leave Mike a message, or should you?

Also, is there a FAQ/wiki for habpanel, that we could add this to? Tried looking myself for any similar issues, but I got many results for each search I did… and obviously you knew the right terms to search for.

Ha! Nailed it! I was more lucky with my search terms I guess :slight_smile:

There is no real source of information apart from here right now, but we can only hope LastPass will solve this soon since it seems to cause problems everywhere… I’ll add a reference to here in the other thread, thanks!