KNX actuator with internal delay


I have an openHAB system running on Raspberry Pi3 and I’m adding items for full functioning.
I have one KNX actuator which controls the garage door. I have one of the button at home (on the wall) that by pressing the button it act as a relay that closes a dry contact of the garage door for 1 second and then release it to be open again.
I didn’t add this item yet to my items list nor the sitemaps.
The problem is that when I’m pressing the button (on the wall), the garage starts opening and 1 sec later it stops - open less than fifth the way. This means that the dry contact got another signal (similar if I press the garage remote control twice). When I turn off the Raspberry Pi3 and press the button (on the wall) it works perfectly and open the door entirely .

Any suggestions?

Any suggestions? Also noticed that some other actuator behave strange. E.g. when I’m turning a light on, it imidiatly turn off and on again without doing nothing on the openhab GUI. Same problems with the blinds; I have a single button at for opening and close blinds - long press open/close and short press stop it in its position. Sometimes when I press the button to stop the blinds, it change the direction. Look like it receives a command from openhab as when the board is off nothing of the above happened

seems you run into this issue OH2 KNX 1.9 Binding - read from KNX results in a write

Thanks for the reference. I have followed the link but couldn’t find the answer to the problem. Even if the garage door is not defined in any of the *.items files still when I’m pressing the physical button at my home, it opens the door a bit and then it stops. only if the OpenHab is turned off, it behaves normally.

Yes, the point is, openHAB seems to repeat all knx telegrams, weather the GA are set or not.

What’s your complete configuration?

  • Operating System at Pi3?
  • Exact Java Version?
  • Exact openHAB Version?
  • Exact knx configuration in question of openHAB (for OH2: knx.cfg or for OH1: openhab.cfg - knx section)?

Thanks for your replay and sorry for the very late response :frowning:

I have same problems with some of the blinds and also from time to time when I’m turning on a light (from the switch on the wall), it turn on and off and at the end return to the on state.

Another strange thing is the delay when using the application on the mobile device. If I’m turning on only one one light it turned it quickly. However if I’m turning some lights one after the other immediately, usually the first light is turned quickly and all the other are turning one by one slowly after.

Here is my configuration:

  • Operating system at Pi3:
    No LSB modules are available.
    Distributor ID: Raspbian
    Description: Raspbian GNU/Linux 8.0 (jessie)
    Release: 8.0
    Codename: jessie

  • Java Version:
    openjdk version "1.8.0_121"
    OpenJDK Runtime Environment (Zulu Embedded (build 1.8.0_121-b42)
    OpenJDK Client VM (Zulu Embedded (build 25.121-b42, mixed mode, Evaluation)

  • openHab version:
    openHAB 2.1.0-1 (Release Build)

  • knx.cfg:

      # KNX gateway IP address 
      # (optional, if serialPort or connection type 'ROUTER' is specified)
      # Local KNX Binding bus address.
      # Use it, when two or more openHAB Instances are connected to the same KNX bus.
      # (optional, defaults to 0.0.0)
      # Ignore local KNX Events, prevents internal events coming from
      # 'openHAB event bus' a second time to be sent back to the 'openHAB event bus'.
      # Note: To send back events second time is a Bug, but for backward compatibility, the behavior is not changed.
      # For new installations, its recommend to set "ignorelocalevents=true"
      # (optional, defaults to false)
      # KNX IP connection type. Could be either TUNNEL or ROUTER (optional, defaults to TUNNEL)
      # Note: If you cannot get the ROUTER mode working (even if it claims it is connected), 
      # use TUNNEL mode instead with setting both the ip of the KNX gateway and the localIp.
      # KNX gateway port (optional, defaults to 3671)
      # Note: If you use eibd, setting to 6720
      # Local endpoint to specify the multicast interface, no port is used (optional)
      # Serial port of FT1.2 KNX interface (ignored, if ip is specified)
      # Valid values are e.g. COM1 for Windows and /dev/ttyS0 or /dev/ttyUSB0 for Linux
      # Pause in milliseconds between two read requests on the KNX bus during
      # initialization (optional, defaults to 50)
      # Timeout in milliseconds to wait for a response from the KNX bus (optional, 
      # defaults to 10000)
      # Number of read retries while initialization items from the KNX bus (optional,
      # defaults to 3)
      # Seconds between connect retries when KNX link has been lost
      # 0 means never retry, it will only reconnect on next write or read request
      # Note: without periodic retries all events will be lost up to the next read/write
      #       request
      # (optional, default is 0)
      ### Auto refresh feature
      # Number of entries permissible in the item refresher queue. 
      # (optional, defaults to 10000)
      # Number of parallel threads for refreshing items. (optional, defaults to 5)
      # Seconds to wait for an orderly shutdown of the auto refresher's 
      # ScheduledExecutorService. (optional, defaults to 5)
      # Use NAT (Network Address Translation)
      #  (optional; defaults to false)

Any ideas? I’m still having this problem!