KNX Binding - I got lost


(Joerg Asma) #1

Good day ,
as I am a beginner please bear with me if I am asking a dumb question. I looked through lots of tutorials but cannot find anything of those great examples working for me.
I installed Openhabian on a Raspberry PI
Here is the summary:
###############################################################################
################# Openhab #####################################################
###############################################################################

Ip = 192.168.1.81

Release = Raspbian GNU/Linux 9 (stretch)

Kernel = Linux 4.14.30-v7+

Platform = Raspberry Pi 3 Model B Rev 1.2

Uptime = 0 day(s). 4:14:0

CPU Usage = 4.34 % avg over 4 cpu(s) (4 core(s) x 1 socket(s))

CPU Load = 1m: 0.42, 5m: 0.42, 15m: 0.37

Memory = Free: 0.03GB (3%), Used: 0.92GB (97%), Total: 0.95GB

Swap = Free: 0.09GB (97%), Used: 0.00GB (3%), Total: 0.09GB

Root = Free: 1.32GB (39%), Used: 2.05GB (61%), Total: 3.55GB

Updates = 0 apt updates available.

Sessions = 2 sessions

Processes = 113 running processes of 32768 maximum processes

###############################################################################

          Welcome to            __  _____    ____  _
        ____  ____  ___  ____  / / / /   |  / __ )(_)___ _____
       / __ \/ __ \/ _ \/ __ \/ /_/ / /| | / __  / / __ `/ __ \
      / /_/ / /_/ /  __/ / / / __  / ___ |/ /_/ / / /_/ / / / /
      \____/ .___/\___/_/ /_/_/ /_/_/  |_/_____/_/\__,_/_/ /_/
          /_/
              openHAB 2.2.0-1 (Release Build)

I am using a gateway from BuschJaeger which is listening on the default port 3671 and has the IP Adr 192.168.1.210

In /etc/openhab2/services I configured the knx.cfg

KNX gateway IP address

(optional, if serialPort or connection type ‘ROUTER’ is specified)

ip=192.168.1.210
type=TUNNEL

KNX gateway port (optional, defaults to 3671)

Note: If you use eibd, setting to 6720

port=3671

Local endpoint to specify the multicast interface, no port is used (optional)

localIp=192.168.1.81

In /etc/openhab2/items I configured in default.items
Switch Licht_Garten_Kugel “Leuchtkugel” (Licht, Garten) {knx=“4/1/0+<4/1/100”}
Switch Licht_Garten_Sterne “Sterne” (Licht, Sterne) {knx=“4/1/1+<4/1/101”}
Switch Licht_Garten_Kugel_Vertauscht (Licht, Garten) {knx=“4/1/100+<4/1/0”}

They are shown in the paperui but are doing nothing.
how can I proceed.
KNX was installed via PeperUI.

best regards
Joerg


(Rich Koshak) #2

I don’t know this binding but the formatting makes what you posted almost impossible to read. Please How to use code fences


(Joerg Asma) #3

Ok - here is the better formatted version, however I was able to read it clearly. Maybe it looks worse on mobile devices, but no on my iMac

###############################################################################
################# Openhab #####################################################
###############################################################################

Ip = 192.168.1.81
Release = Raspbian GNU/Linux 9 (stretch)
Kernel = Linux 4.14.30-v7+
Platform = Raspberry Pi 3 Model B Rev 1.2
Uptime = 0 day(s). 4:14:0
CPU Usage = 4.34 % avg over 4 cpu(s) (4 core(s) x 1 socket(s))
CPU Load = 1m: 0.42, 5m: 0.42, 15m: 0.37
Memory = Free: 0.03GB (3%), Used: 0.92GB (97%), Total: 0.95GB
Swap = Free: 0.09GB (97%), Used: 0.00GB (3%), Total: 0.09GB
Root = Free: 1.32GB (39%), Used: 2.05GB (61%), Total: 3.55GB
Updates = 0 apt updates available.
Sessions = 2 sessions
Processes = 113 running processes of 32768 maximum processes
###############################################################################

          Welcome to            __  _____    ____  _
        ____  ____  ___  ____  / / / /   |  / __ )(_)___ _____
       / __ \/ __ \/ _ \/ __ \/ /_/ / /| | / __  / / __ `/ __ \
      / /_/ / /_/ /  __/ / / / __  / ___ |/ /_/ / / /_/ / / / /
      \____/ .___/\___/_/ /_/_/ /_/_/  |_/_____/_/\__,_/_/ /_/
          /_/
              openHAB 2.2.0-1 (Release Build)

I am using a gateway from BuschJaeger which is listening on the default port 3671 and has the IP Adr 192.168.1.210

In /etc/openhab2/services I configured the knx.cfg

# KNX gateway IP address
# (optional, if serialPort or connection type 'ROUTER' is specified)
ip=192.168.1.210


# Local KNX Binding bus address.
# Use it, when two or more openHAB Instances are connected to the same KNX bus.
# (optional, defaults to 0.0.0)
#busaddr=

# Ignore local KNX Events, prevents internal events coming from
# 'openHAB event bus' a second time to be sent back to the 'openHAB event bus'.
# Note: To send back events second time is a Bug, but for backward compatibility, the behavior is not changed.
# For new installations, its recommend to set "ignorelocalevents=true"
# (optional, defaults to false)
#ignorelocalevents=
# KNX IP connection type. Could be either TUNNEL or ROUTER (optional, defaults to TUNNEL)
# Note: If you cannot get the ROUTER mode working (even if it claims it is connected),
# use TUNNEL mode instead with setting both the ip of the KNX gateway and the localIp.
type=TUNNEL
# KNX gateway port (optional, defaults to 3671)
# Note: If you use eibd, setting to 6720
port=3671
# Local endpoint to specify the multicast interface, no port is used (optional)
localIp=192.168.1.81

In /etc/openhab2/items I configured in default.items

Switch Licht_Garten_Kugel "Leuchtkugel" (Licht, Garten)  {knx="4/1/0+<4/1/100"}
Switch Licht_Garten_Sterne "Sterne" (Licht, Sterne) {knx="4/1/1+<4/1/101"}
Switch Licht_Garten_Kugel_Vertauscht (Licht, Garten)  {knx="4/1/100+<4/1/0"}

They are shown in the paperui but are doing nothing.
how can I proceed.
KNX was installed via PaperUI.

best regards
Joerg


(Udo Hartmann) #4

As you are using the stable release of openHAB2, you are still on knx1 binding. The Items are visible through Paper UI (in Configuration-Items), but you can’t control the items from Paper UI Control page, as this Control Page is for Things (i.e. their Channels), not items.

You have to create a sitemap to control the items (by using Basic UI or Classic UI). It’s also possible to use HABpanel (but this is more complex to configure).

As you can see, in the original post there are several # missing, because discourse made an automatic formatting (Topic). It’s really hard to decipher those parts. And after all, it’s good style anyway :wink:


(Joerg Asma) #5

Hello Udo,
thanks for the information - I tried to do it accordingly.
I created the knx.things

ridge knx:ip:bridge [
    ipAddress="192.168.1.210",
    portNumber=3671,
    localIp="192.168.1.81",
    type="Tunnel",
    readingPause=50,
    responseTimeout=10,
    readRetriesLimit=3,
    autoReconnectPeriod=1,
    localSourceAddr="0.0.0"
] {
    Thing device generic [
        address="1.2.3",
        fetch=true,
        pingInterval=300,
        readInterval=3600
    ] {
        Type switch        : demoSwitch        "Light"            [ ga="4/1/0+<4/1/100" ]
        Type switch        : Licht_Garten_Kugel "Leuchtkugel"     [ ga="4/1/0+<4/1/100" ]
        Type switch        : Licht_Garten_Sterne "Sterne"         [ ga="4/1/1+<4/1/101" ]
        Type switch        : Licht_Garten_Kugel_Vertauscht        [ ga="4/1/100+<4/1/0" ]
      }
}

after that knx.items

#KNX.items
Switch Licht_Garten_Kugel               "Light [%s]"         <light> { channel="knx:device Bridge:generic:Licht_Garten_Kugel }
Switch Licht_Garten_Sterne              "Light [%s]"         <light> { channel="knx:device Bridge:generic:Licht_Garten_Sterne }
Switch Licht_Garten_Kugel_Vertauscht    "Light [%s]"         <light> { channel="knx:device Bridge:generic:Licht_Garten_Kugel_Vertauscht }

… and a default.sitemap

sitemap knx label="KNX Demo Sitemap" {
  Frame label="Demo Elements" {
    Switch item=demoSwitch
    Switch item=Presence_JoergsMobile label="Jörg ist zu Hause"
    Switch item=Licht_Garten_Kugel
    Switch item=Licht_Garten_Kugel_Vertauscht
    Switch item=Licht_Garten_Sterne
  }
}


but I do not get anything going.
Is there anybody that could send me his or her configuration files to get it going or knows what I am doing wrong?

I have no idea anymore!

best regards
Joerg


(Udo Hartmann) #6

Did you change to OH2.3.0 nightly? Otherwise, you got me wrong.

  • OH2.2 (aka stable) -> knx1 binding -> No Things, no channels, but knx.cfg and direct linking in .items file (i.e. {knx="…"}
  • OH2.3.0 (aka nightly) -> knx2 binding -> no knx.cfg, no direct linking, but a bridge, things and channels.

(Joerg Asma) #7

Hi,
No I didn‘t switch but maybe I should do it.
I was using the knx documentation on openhap to reset my self (and the config files)
I will update and then see if i can proceed?
Best regards
Joerg


(Udo Hartmann) #8

Obviously there is a problem to change the abstract by switching the version. You have to explicitly search for knx1 (right upper corner) to find the knx1 binding: https://docs.openhab.org/addons/bindings/knx1/readme.html

But yes, as knx1 under OH2 is known to be … defective… it’s a good idea to switch directly to OH2.3.0 nightly - and knx2 will be the recommended binding in OH2.3 stable anyway.