KNX Binding OH 3 Docker - Connection Failed


I created a device and connect via tunneling to the bus.
It works now but every minute when the binding tries to connect to the interface again i get his messages:

2021-02-17 17:05:20.195 [ERROR] [Xnet/IP Tunneling] - establishing connection failed, timeout connecting to control endpoint /
2021-02-17 17:05:20.199 [WARN ] [.core.thing.binding.BaseThingHandler] - Handler IPBridgeThingHandler tried updating the thing status although the handler was already disposed.

i am able to control the devices on the bus and read back values as well.
but i cannot get rid of this error messages.
any ideas?
i forwarded the port 3671 in docker and i had to set the parameter useNAT = true or i would not be able to establish a tunneling connection to my knx router.

it does not make any difference if i have the group monitor active or not.

Hi Jonas,
this is how I start openhab in Docker (I am using also KNX):
docker run
–restart unless-stopped
–name myopenhab
–hostname myopenhab
–network host
–volume /etc/localtime:/etc/localtime:ro
–volume /etc/timezone:/etc/timezone:ro
–volume /mnt/data/docker/openhab/conf:/openhab/conf
–volume /mnt/data/docker/openhab/userdata:/openhab/userdata
–volume /mnt/data/docker/openhab/addons:/openhab/addons
–env USER_ID=998
–env GROUP_ID=998
myopenhab:2020-05-21 /openhab/

I use knxd as the KNX router. This also run in a docker container:
docker run
–restart unless-stopped
–network host
–name knxd
–hostname knxd

Works smoothly in this setup.

1 Like

Thank you!
i see you are using linux. unfortunately i cannot use the
-network host
parameter on mac os.
strangely it works but i am getting a connection timeout every time it tries to reconnect.
I will give knxd a try anyway maybe it solves my problem.

thank you!


i don’t quite get why, but it is working great now.
I just docker-composed up again and the network error is gone …