KNX dimming not working correctly after upgrading to 4.1.0

Hi,
I have a problem with the KNX binding after updating to oh 4.1.0.
I have following config:

  • MDT Dimmaktor where i restrict the channel to 80% dimming
  • MDT Switch for turning on the lights

When Openhab 4.1.0 is running, and i turn on the physical MDT switch, the light is always turning on to 100%
When Openhab 4.1.0 is NOT running, and i turn on the physical MDT switch, the light is turning on to 80%

When 3.4.5 is running, it is working perfectly.
I hope my explanation is understandable :slight_smile:

Otherwise i will try it with more details.
Thank you very much.
Chris

Not very sure but if it’s hardcoded in the actuator usually it would mot be affected by on values to go full brightness.
This is from MDT

4.4.4 Limiting the dimming range of the lamp

If the technically possible dimming range (1-100%) is to be 
limited to a smaller value, this is possible by setting a 
minimum and maximum brightness value for each channel 
individually. If the dimming range is limited, the channel 
will only move within the set limits. This also has 
consequences for other parameters: if, for example, a 
maximum brightness value of 85% is set and a switch-on 
value of 100% is selected, the channel will also switch on at 
the highest value of the maximum permissible value of 
85%. Exceeding this value is no longer possible.
The setting of a dimming range is especially useful if 
certain values should not be reached for technical reasons.
Figure 10: Limitation of dimming range
Example:
minimum brightness value = 25%, maximum brightness value = 85%, switch-on value = 100%
• Telegram value On --> brightness value 85%
• Telegram value 50% --> brightness value 50%
• Telegram value 95% --> brightness value 85%
• Telegram value 15% --> brightness value 25%
• Telegram value Off --> brightness value 0%

So check your ets config. I also know MDT offers day night channels where you can limit the max and minimum brightness maybe you have that linked with openhab. Another possible cause is the misuse of status group address see latest changes to knx binding but again that would make sense if you did not have that harcoded limit in the actuator.

Hi,

Thank you for your answer.

I already worked with the functions for limiting the MDT dimming. For day, for night and so on.
When OH 4 is not running, the limits are working perfect.
Then i turn on Openhab (running on a Synology), and the limits aren’t working anymore. I have 3 dimming actuators with different firmware states. On all 3 actuators the limits are not working when Openhab is running.
In ETS i just switch on the channel (to the MDT channel limit), i send no percentages or so.

Thank you
Chris

Alright. So you assume it’s the knx binding sending bogus telegrams ? In any case even if it did the actuator should keep that limit.
So maybe give more information about your ets config things rules etc so we can have a look at it and maybe find what it’s send to the actuator.

Yes, I think the binding is sending incorrect telegrams.

When OH 4 is turned off, i get the “normal” Log in ETS. Channel is limited to 80%:

When OH 4 is on, the same action look likes this:

The binding is sending two on/off actions with 100%. Why?
Is there anything else, i can send you, for finding the error?

THX
Chris

From what I can see an on commande to the actuator result in an 80 percent absolute status but the same command send to the actuator makes openhab to send the 100 percent value. But that is not bogus behaviour. Show the thing and items related to that actuator to see why openhab respond to on command coming from the bus.

here is the thing:

UID: knx:device:a4aa98d676:0e83e4544d
label: Dimmaktor EG
thingTypeUID: knx:device
configuration:
  pingInterval: 600
  address: 1.1.52
  readInterval: 0
  fetch: true
bridgeUID: knx:ip:a4aa98d676
channels:
  - id: Esszimmer_Spots
    channelTypeUID: knx:dimmer-control
    label: Esszimmer Spots
    description: ""
    configuration:
      increaseDecrease: 1/2/21
      position: 1/2/22
      switch: 1/2/20

Thats the Item:

And then the docs

Control channel types (suffix -control) are used for cases where the KNX bus does not own the physical state of a device. This could be the case if e.g. a lamp from another binding should be controlled by a KNX wall switch. When a GroupValueRead telegram is sent from the KNX bus to a *-control Channel, the bridge responds with a GroupValueResponse telegram to the KNX bus.

You are my hero! The channel type was wrong! After deleting one “test” channel, is was working.
So it was bad luck, that is was working for 2 years now :slight_smile:?

I changed one channel now, and i can switch on dimming light in OH on, but the status in OH is wrong (always 100%), instead of e.g. 25%.

Can you give me a notice, how i have to register the GA?

In ETS i have:
1/2/20 is ON/OFF
1/2/21 is dimming relativ
1/2/22 is dimming absolut
1/2/23 is Status for ON/OFF
1/2/24 is Status for dimming

I tried this way:

THX
Chris

Ok, now i solved it.

1/2/20+<1/2/23
I have forgotten the “<”. Now the status is working!
THX
Chris