KNX homelynk controller

Tags: #<Tag:0x00007f616fa433a0>

i want to connect my KNX system with openhabian software using raspberry pi3
having KNX homelynk Controller (Made Schneider electric) to connect my system with google home for voice control , but i am unable to add thing and item in inbox .
can anyone help me on this .

What OH version is installed and do you see anything in the logs regarding KNX?

i am using openhab version 2.4.0
there is an error showing KNX github issue

Now i am able to see my knx controller gateway as a thing which is added manually by me (KNX bindings installed), but it is not coming in control . can anyone tell how can i
take it to control dashboard ,so that i can control my KNX system.

I didn’t manage to successfully auto-discover the things on KNX bus (some devices does not respond - for example most of knx-rf switches), so it is better to use .things/.items files. Also giving the fact that KNX has relatively stable topology, i think configuration via files is better.
For each KNX device, define one thing inside the bridge:

Thing device LR_AKK03 "Kitchen Light Actuator"@"Kitchen" [address="1.1.16", fetch=false, pingInterval=1200, readInterval=0] {
	Type switch : LR16_AKK3_G0 "Kitchen Spot" [ga="1/2/0+<1/2/1"]
	Type switch : LR16_AKK3_G11 "Kitchen Main" [ga="1/2/2+<1/2/3"]
	Type switch : LR16_AKK3_G22 "Balcony Lights" [ga="1/2/4+<1/2/5"]
}

address is your device address, ga is group address (you have to browse in ETS (if you have project) or listen to the bus & use manufacturer documents for each device GAs). That is most time consuming task.
Then in .items:

Switch Kitchen_LA_Spot “Kitchen Spot” (gKitchen,gKNX,gLights) {channel=“knx:device:bridge:LR_AKK03:LR16_AKK3_G0”}
Switch Kitchen_LA_Main “Kitchen Main” (gKitchen,gKNX,gLights) {channel=“knx:device:bridge:LR_AKK03:LR16_AKK3_G11”}
Switch Balcony_LA_Spot “Balcony Lights” (gBalcony,gKNX,gLights) {channel=“knx:device:bridge:LR_AKK03:LR16_AKK3_G22”}

The naming of the channels is up to you (I’m using Location_DeviceType_ChanID here)

Thank you Mr. @Vlad1024 Vlad1024 for your reply.
i want to connect my KNX home controller (Homelynk - Schneider electric made) to openHAB . It is showning online (Manually Added in KNX bindings , IP Gateway ) but not able to control . Please say if you have any solution for this.

there is openhabian github issue is coming while installing knxd in openhabian (2.4.0)

Hello kishor, did you manage to configurate your Homelynk?

I also have this system, and I’m trying to install it in OpenHab

Hello @RedC Chris , sorry to say Chris but still I am unable to control my homelynk with openhab.
Issue is, my Homelynk controlling is working on TP/UART mode when I switched it to Routing or tunneling it stopped controlling .
I am also unable to programmed (using ETS5) it when it is in routing or tunneling mode .
If u will find any solution in that please inform me too. Thank you

@kishor

Hello Kishor,

I managed to install the HomeLynk into Openhab. All the modules are online, the only thing left to do is create the group addresses in OpenHab.

What I did is the following:

  1. Add the KNX binding to OpenHab
  2. Add a KNX IP interface or router
  3. Settings:
    IP Connection Type: Tunnel
    Network Address: Local network ip of your homelynk (e.g. 192.168.xxx.xxx)
    Port: left default port number
    Local Network Address: left empty
    Use Nat: yes
    Local Device Address: the device addres e.g. 1.1.x
    Other settings I didn’t change

To link the other modules in OpenHab to your HomeLynk:

  1. Add An addressable basic KNX device
  2. Bridge Selection: here you select the HomeLynk device
  3. Address: the device address e.g. 1.1.x
  4. Fetch: Yes

This worked for me, I hope this works for you too

Thank you @RedC for sharing the details.
but unfortunately it’s not working in my case , what is the mode (TP/UART , Routing ,tunneling or tunneling with NAT) of your homelynk in ETS5 programming.