KNX - How to set-up rollershutter limits, max and min

Tags: #<Tag:0x00007fc1feaca5e0> #<Tag:0x00007fc1feaca4c8> #<Tag:0x00007fc1feaca400>
  • Platform information:

    • Hardware: RaspberryPi 3+
    • OS: Openhabian
    • Java Runtime Environment:
    • openHAB version: 2.5.1
  • Issue of the topic:
    The blind responds good in both Openhab and HABpanel but actually works in 36 steps, from 0 to 36 (full open / fully closed) in pulses from the KNX console.

  • Configurations

    • Items

knx.items

Rollershutter persianaterraza "Persiana de la terraza [%d %%]"   <blinds>          { channel="knx:device:bridge:Shutter1:persianaterraza",alexa="Blind" }
Switch        luzsofa         "Luz del sofá [%s]"                <light>           { channel="knx:device:bridge:generic:luzsofa",alexa="Switchable" }

  • Sitemap configuration related to the issue

knx.sitemap

sitemap knx label="KNX Demo Sitemap" {
  Frame label="Pruebas" {
    Rollershutter item=persianaterraza
    Switch        item=luzsofa
  }
}

knx.things

Bridge knx:ip:bridge "KNX IP Interface" [     // Name and label of Bridge
    type="TUNNEL",                            // Type of connection
    ipAddress="192.168.1.*"                  // IP address of KNX/IP Gateway
    
] {
    Thing device generic []
    {
        Type switch        : luzsofa          "Luz del sofá"            [ ga="0/3/7+<0/3/7" ]


    }
    Thing device Shutter1 []
    {
        Type rollershutter : persianaterraza  "Persiana de la terraza"  [ upDown="1/0/0", stopMove="1/0/1", position="5.001:1/0/2+<1/0/3" ]
    }
}

First of all say thank you to everyone posting and answering since reading dozens of posts related I have been able to make my KNX/alexa run in this OS and platform that I never handle before, specially thanks to @Udo_Hartmann who appears in many solved post which comments really helpful and maybe can help out this time as well. It was not easy but I got reasonable success so far.

At the moment I have just modeled a few components which I have simplified above since they were repetitive. Only two sort of things: lights and blinds

The target is just make the system recognize the KNX console, identify properlly every item, make them work and then link them to Alexa. Well, target accomplished so far. At this point I need to properly fix it, to make it work as I wish.

The issue comes as follows:
Blind is working in a 36 steps or pulses based. So the range of the blind goes from 0 to 36 and makes no action over 36 since it is fully closed.
In the same way appears said before in HABpanel. I can set the slide from 0 to 36 since range over 36 is useless, but the target would be teach the system the 36 position should be the 100 one instead of working with a weird range such 0-36.

At some point I think somewhere I have read this can be solved setting up max and min limits in things file, should this is the correct way. Not sure whether in the community or maybe in BK Hobby tutorials (which I found really helpful) I think I have seen it can be done.
May some of you guys help out with this?

Beyond of this, as further step I need to solve the way Alexa understand instructions. She acts to my demands but not right since when I tell her “Alexa raise the blind” she does in the oposite way and viceversa and not full but parcial move of the blind
I am aware of Alexa skill metadata configuration but I would like firstly fix the issue above, make it work properly in HABpanel and then Alexa.

Rollershutter Blind "Blind" {alexa="RangeController.rangeValue" [category="INTERIOR_BLIND", friendlyNames="@Setting.Opening", supportedRange="0:100:10", unitOfMeasure="Percent", actionMappings="Close=0,Open=100,Lower=(-10),Raise=(+10)", stateMappings="Closed=0,Open=1:100"]}

Thanks in advance.

Hi,

Just move up my post in order of someone may help out earlier than my topic gets unnoticed down in the list of forgotten tales.

Thanks