KNX/IP Gateway COMMUNICATION_ERROR

Hi! I have been searching for days but I can’t find anything pointing me in the right direction.

I am running openHAB 4.0.4 in Docker on my Synology NAS. Everything has been working great for a long time but suddenly the light switches stopped working. I might have updated something, I am not sure.

I get the error:
Status:
OFFLINE
COMMUNICATION_ERROR
Communication timeout (KNXTimeoutException, timeout connecting to control endpoint 192.168.2.250:3671)

If I ping “192.168.2.250” I get immediate replies and the status devices on the KNX unit shows it got connection so I don’t think it is anything hardware related. The unit is a “abb i-bus knx ips/s 3.1.1”.

This is my configuration:
UID: knx:ip:5483887426
label: KNX/IP Gateway
thingTypeUID: knx:ip
configuration:
useNAT: true
readRetriesLimit: 3
ipAddress: 192.168.2.250
autoReconnectPeriod: 60
localIp: 192.168.2.60
localSourceAddr: 0.0.0
readingPause: 50
type: TUNNEL
portNumber: 3671
responseTimeout: 10

Any ideas? I read some post about turning on NAT will magically fix problems no one seems to understand why but that didn’t work for me atleast :slight_smile:

2023-11-25 14:51:40.365 [ERROR] [Xnet/IP Tunneling 192.168.2.250:3671] - establishing connection failed, timeout connecting to control endpoint 192.168.2.250:3671

2023-11-25 14:53:22.244 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing ‘knx:ip:cf1bb7487b’ changed from UNKNOWN to OFFLINE (COMMUNICATION_ERROR): Communication timeout (KNXTimeoutException, timeout connecting to control endpoint 192.168.2.250:3671)

Have you tried restarting the abb IP gateway?
Remove the Nat unless you are not on a different network.

Yes I have tried restarting the abb gateway and also removed NAT. However I downloaded ABB i-bus tool and when searching the network for the unit I cannot find it, but as I mentioned in my first post I can ping it.

Most likely it failed to load the program can you try a full download from ets ?

Hmm ETS gives me: “Failed to read device description from 192.168.2.250:3671, but Ping succeeded”

*Edit: I also tried powering it with PoE instead of the power supply but with the same result, I might have to change my mind about it not being hardware related, I don’t know what else to try.

Without knowing to much information about your topology how did you connect to your bus ? If you have a knx USB try with that to do a full download to write the program to it.

No I only got this IP Gateway to connect to the bus, not knowing I guess it would be cheaper to get a USB unit to try your suggestion. Do you know enough about the USB devices to recommend one for me? Thanks for all your help so far.

I would recommend not investing in an usb if you don’t have it. Buy another gateway preferably router gateway if not the same and try again and if the old one works good if not you have a backup so investment is not lost.

Thanks! I’ll just check with ABB first if they have any suggestions, then I start looking for a new unit.

I reached out to the ABB support but didn’t get anywhere there which is understandable since it is a 6 year old product so not much to say about that.

Just a question, the “Telegram” light should be lit when connection to the KNX bus has been made and blinking during traffic? Mine is constantly off.

No ideea don’t know nothing about abb but if it’s labeled like that try turning lights on and off while looking and it should be lit that is if the led is still functional.

The manual reads:

Telegram

  • The LED lights up when the interface is connected to a TP network and the startup process is
    complete (see “On” LED).
  • The LED flashes when the device detects activity on the KNX subline TP1 (twisted pair 1), e.g. when
    data is exchanged.

So if everything is working the led would be lit and during traffic it should be blinking, right?

Yes according to that. But it can also be broken or the software that control it in an error state. With complicated devices like that the time spent on debugging or fixing is not worth it better change it.