Knx mdt jal-01up.02


I’m using Openhab2 on a Pine64 preinstalled and the KNX1 Binding.
I can’t get my Actors working. I have multiple MDT JAL-01UP.02.

I have tried multiple Settings in my items file and the sitemap.
As Switch, Rollershutter, Dimmer etc.

The Actor is set as Rollershutter.

My Items File:

Switch Roll_AZ “Rollade” (gRoll) {knx=“1/3/0”}

My Sitemap:

sitemap Rolladen label=“Rolladen im Haus” {
Frame label=“Erdgeschoss” {
Text item=Roll_AZ
Frame label=“1. Etage” {
Switch item=Roll_AZ

My knx.cfg is set to ROUTER.

Maybe someone can help me to get them working.


First thing:
Does openHAB connect to KNX? Can you monitor the bus using ETS?
Second thing:
Please post your knx.cfg file!
Third thing:
You should define the item as a rollershutter item.

1 Like

As far as I can see, yes. And I can Monitor using ETS5 and ETS Inside.

[INFO ] [nx.internal.connection.KNXConnection] - Established connection to KNX bus on in mode ROUTER.


# KNX gateway IP address
# (optional, if serialPort or connection type 'ROUTER' is specified)

# Local KNX Binding bus address.
# Use it, when two or more openHAB Instances are connected to the same KNX bus.
# (optional, defaults to 0.0.0)

# Ignore local KNX Events, prevents internal events coming from
# 'openHAB event bus' a second time to be sent back to the 'openHAB event bus'.
# Note: To send back events second time is a Bug, but for backward compatibility, the behavior is not changed.
# For new installations, its recommend to set "ignorelocalevents=true"
# (optional, defaults to false)

# KNX IP connection type. Could be either TUNNEL or ROUTER (optional, defaults to TUNNEL)
# Note: If you cannot get the ROUTER mode working (even if it claims it is connected),
# use TUNNEL mode instead with setting both the ip of the KNX gateway and the localIp.

# KNX gateway port (optional, defaults to 3671)
# Note: If you use eibd, setting to 6720

# Local endpoint to specify the multicast interface, no port is used (optional)

# Serial port of FT1.2 KNX interface (ignored, if ip is specified)
# Valid values are e.g. COM1 for Windows and /dev/ttyS0 or /dev/ttyUSB0 for Linux

I already defined the item as rollershutter but it made no difference.

What KNX/IP interface are you using: manufacturer/model?

It’s a MDT SCN-IP100.02 (IP Router)

As @george.erhan wrote, you need to use a Rollershutter item type.

Here is my example of a RS item using a Gewiss Actuator with 4 GAs defined:

/* Ground Floor Rollershutters = knx=Up/Down, Step/Stop, GoTo, Status */
Rollershutter	P11_J1		"P11_J1"		<rollershutter>	(gGF_P11_Living,gShutters,gKNX)		{knx="2/0/0,2/0/1,2/3/0+<2/2/0"}

Then, in sitemap:
Default item=P11_J1

Is this your first KNX item in OH2? (or you have other stuff working already?)
If it is the first, you may need to check if the KNX/IP Gateway allows the routing of the telegrams.
You can put the KNX binding in TRACE log level to check if you get any replies from the KNX world.

In openHAB console:

log:set TRACE org.openhab.binding.knx
log:set TRACE
1 Like

Coincidentally I know this very well!
Have you tried to filter (you also have the option of routing all GA to IP) GA telegrams to ip?
Have you downloaded through ETS the router configuration?
About the rollershutter item: it has to have more than one GA in the binding definition! It has to have UP/DOWN GA, STOP GA, POSITION (BYTE) GA.

1 Like

Its working now.
I just used item rollershutter and added 3 GA.

Thanks for your help.

1 Like