KNX Shutter (Blinds) whats wrong here - how to handle it

Tags: #<Tag:0x00007fc3eda3aa58> #<Tag:0x00007fc3eda3a990>

Hi
I’m struglling here to put my first KNX Shutter thing as Online I have other devices like DaliBox/switch online, but can’t put the shutter device:


Here you can find what I have in the .things file:

Thing device Th_ACTinBOXMAX6_0014 "ACTinBOX MAX6 Piso-1 #1" [
    address="0.0.14",
    fetch=true,
    pingInterval=300, 
    readInterval=3600 ]
    {
        /* Ground Floor Rollershutters = knx=Up/Down,Step/Stop,GoTo+<Status */
        Type rollershutter : Ch_Shutter_0014_A "Estore Esq. Sala" [upDown="0/2/2+0/2/152", stopMove="0/2/3+0/2/152"]

//Type rollershutter : demoRollershutter “Shade” [ upDown=“4/3/50+4/3/51”, stopMove=“4/3/52+4/3/53”, position=“4/3/54+<4/3/55” ]
//Type rollershutter : Ch_Shutter_0014_B “Estore Meio Sala” [upDown=“1/4/2+<1/4/152”, stopMove=“1/4/3+<1/4/152”, position="+<1/4/151"]
//Type rollershutter : Ch_Shutter_0014_C “Estore Dir. Sala” [upDown=“1/5/2+<1/5/152”, stopMove=“1/5/3+<1/5/152”, position="+<1/5/152"]

    } 

You can see commented others channels but i have commented to be sure where is the issue.

Below you can confirm the GAs
image

Adding this issue, I would add one more doubt. This shutter has blinds also.
The device has the object to define/get status position of the blinds. But didn’t find how to do it in the things file, in rollershutter type.

thanks in advance

That is not a valid network ip address

That s the Thing/Device Address not the Bridge IP address.

1 Like

OK, I related that to “ping” to mean ICMP ping across the network.

The correct channel definition is

Type rollershutter : Ch_Shutter_0014_A "Estore Esq. Sala" [ upDown="0/2/2", stopMove="0/2/3", position="0/2/152" ]

As I don’t speak spanish I’m not sure, but I guess 144 is the position status, where 146 is the command to drive the shutter to the position. You should add another GA to this CO as well and add it to the position parameter (as first GA, then openHAB will send absolute position commands).

Please do not use fetch=true or readInterval!=0, fetch is an experimental parameter, readInterval is to read all readable GA frequently. This should not be necessary.

Hi Udo

Thanks for you quote:

Changed to:
/ACTinBOX MAX6 Piso-1 #1/
Thing device Th_ACTinBOXMAX6_0014 “ACTinBOX MAX6 Piso-1 #1” [
address=“0.0.14”,
fetch=false,
pingInterval=300,
readInterval=0 ]
{
/* Ground Floor Rollershutters = knx=Up/Down,Step/Stop,GoTo+<Status */
Type rollershutter : Ch_Shutter_0014_A “Estore Esq. Sala” [upDown=“0/2/2”, stopMove=“0/2/3”, position= “0/2/152”]
}

But stills Offline. However I can handle it in PaperUI. For now I will leave it as Offline. Minor Issue.

New issue I have realized is that I can’t handle the shutter in little steps, like i used to do with the Buttons and in Knx Touchs. Little touch the shutter just moves a little step. Long touch it moves completely to up/down. Isn’t possible to do it?

Regarding Blinds, there is any syntax in order to handle the Blinds?

thanks

Then address is not reachable (so maybe wrong address). As you don’t need to set an address at all, delete address, fetch and pingInterval.

In question of step-move, openHAB does not directly support lamella control. You have to use another channel for that. If you use simple blinds, the step commands are useless anyway.

1 Like

Even with simple blinds the step command can be for example 5 seconds. So it is definitely not useless.

1 Like

Hi,
after removing the address it appears as “Online”. It is completely a new to me. The thing don’t need the address of device??

Regarding Shutter with Lamellas need to investigate further i’m affraid i need to apply Rules, right?
For now as it is my first OH project will leave it as a simple Shutter. But in future need to investigate more because all my Shutters are Shutter/Lamellas.

many thanks.

I am using 1 device to check if the bus is alive, pinging more than 1 device doesn’t help, either its up or down…

No Thing needs an address, this is just nice to have. If openHAB succeeds in pinging the address (i.e. receiving an answer) it will set the thing status accordingly, but this will not affect the functionality (i.e. even if a thing is marked as offline, openHAB will send and receive through the channels.)

If setting the step command to 5 Seconds, there is no way to stop the blinds immediately, as there is no stop command but only the step command to interrupt an up/down command.

Of course one could use steps to control the shutters in steps, but why?
I’m absolutely happy with setting my shutter to e.g. 50% (shading position) or to 75% (a door blind, the shutter is closed but for the last 10 Centimeters, so with the opened door there will be some air exchange).

Please be aware that openHAB will only send single step commands. This option is meant to control lamellas, not simple blinds.

That’s not true. A step will always stop a step or move.

P.S.: I would only use this if absolute positioning is not supported by the actuator.

Says whom? The manual of my actuator says differently…

The manual of your actuator can’t know how openHAB does work. :wink:

How do you send frequent step commands from openHAB?

Well, in fact, you could do it via sitemap by using sendFrequency parameter, but you would have to use Classic UI for this to take effect.
Of course you could send commands frequently by using a rule, but then again, why?
It’s a lot easier to start a timer and automatically stop the shutter instead of sending x steps.

1 Like

I misread your sentence. I thought the second part was generic for KNX. Of course I would in OH and in KNX only send either STEP or MOVE and maybe stop it in OH using a timer.

1 Like