KNXbinding is not present

Hi im totally new with openhab
but working with knxsystem .
now i wondering what to do with the bindings ,it does`nt seem to work for me
ive tried to set config to router and tunnel
When i start the openhab it writes[KNXbinding configurations is not present]
what does that mean ?

openHAB1 or openHAB2?

Hi Udo thanks for being so fast.
I downloaded Openhab runtime for windows from your download page.

Do you mean
There is no download for windows except the openHAB Designer, as openHAB is written in Java it is almost OS-independly :slight_smile:

So did you setup the knx binding in openhab.cfg?
What about the configuration (only knx part)?

Yes i did the config in openhab.cfg
And only did the knx part.

So please show us your knx configuration from openhab.cfg :slight_smile:

And maybe you set the logging level for the KNX binding to DEBUG and provide that part of the log also here.

I dont know were to set the logging level?
This is my file what is wrong?

Hm. Don’t see a file…

For the logging level see here:
Scroll to the very end, it’s just one line in a config file.

Cant you see this file

Sorry I don’t see a file. Maybe u just copy&paste the content here in?

HI i dont seem to get this to work ,is it some other configurations that i must do.
when i start openhab it says that knx binding is not present.


KNX gateway IP address

(optional, if serialPort or connection type ‘ROUTER’ is specified)


Local KNX Binding bus address.

Use it, when two or more openHAB Instances are connected to the same KNX bus.

(optional, defaults to 0.0.0)


Ignore local KNX Events, prevents internal events coming from

‘openHAB event bus’ a second time to be sent back to the ‘openHAB event bus’.

Note: To send back events second time is a Bug, but for backward compatibility, the behavior is not changed.

For new installations, its recommend to set “knx:ignorelocalevents=true”

(optional, defaults to false)


KNX IP connection type. Could be either TUNNEL or ROUTER (optional, defaults to TUNNEL)

Note: If you cannot get the ROUTER mode working (even if it claims it is connected),

use TUNNEL mode instead with setting both the ip of the KNX gateway and the localIp.


KNX gateway port (optional, defaults to 3671)

Note: If you use eibd, setting to 6720


Local endpoint to specify the multicast interface, no port is used (optional)


Serial port of FT1.2 KNX interface (ignored, if ip is specified)

Valid values are e.g. COM1 for Windows and /dev/ttyS0 or /dev/ttyUSB0 for Linux


Pause in milliseconds between two read requests on the KNX bus during

initialization (optional, defaults to 50)


Timeout in milliseconds to wait for a response from the KNX bus (optional,

defaults to 10000)


Number of read retries while initialization items from the KNX bus (optional,

defaults to 3)


Seconds between connect retries when KNX link has been lost

0 means never retry, it will only reconnect on next write or read request

Note: without periodic retries all events will be lost up to the next read/write


(optional, default is 0)


Auto refresh feature

Number of entries permissible in the item refresher queue.

(optional, defaults to 10000)


Number of parallel threads for refreshing items. (optional, defaults to 5)


Seconds to wait for an orderly shutdown of the auto refresher’s

ScheduledExecutorService. (optional, defaults to 5)


Did you copy the knx addon to the addons folder?

For code pasting, please use backticks ` around the code to prevent malforming (e.g. the # will end up in Headline style)