KNXD via BAOS 838 Module OH3 - can't make it work

Hi folks,

I still have an open thread on that matter but it’s quite a while ago I’ve started this. In the meantime, I’ve updated to the most recent openhabian and even got the KNXD running with the Weinzierl Module (BAOS 838). Unfortunately only once, then knxd quits with this message within the journal:

Sep 11 09:05:20 openhabian knxd[2514]: E00000044: [32:C.ft12cemi] reset timed out
Sep 11 09:05:20 openhabian knxd[2514]: F00000105: [27:C.ft12cemi] Link down, terminating
Sep 11 09:05:20 openhabian systemd[1]: knxd.service: Main process exited, code=exited, status=1/FAILURE

Any ideas - I haven’t the slightest one and even don’t know where to start.

Besides, I installed the brigde while obeying all the comments around, it’s Online (even though KNXD quit in the meantime).

UID: knx:serial:8819d0fefc
label: KNX FT1.2 Interface
thingTypeUID: knx:serial
useCemi: false
autoReconnectPeriod: 60
serialPort: /dev/ttyAMA0
readingPause: 50
readRetriesLimit: 3
responseTimeout: 10

Installed a generic device - Online.
Installed a channel for a simple switch - no problems.

UID: knx:device:8819d0fefc:9cf952e415
label: KNX Device
thingTypeUID: knx:device
pingInterval: 0
readInterval: 0
fetch: false
bridgeUID: knx:serial:8819d0fefc

  • id: L_A1L_BIRD_EIN_AUS
    channelTypeUID: knx:switch-control
    label: L_A1L_BIRD_EIN_AUS
    description: “”
    ga: 1/0/5+<1/6/5

Linked an item, created a page, added a card.

label: Overview

  • component: oh-block
    config: {}
    - component: oh-grid-row
    config: {}
    - component: oh-grid-col
    config: {}
    - component: oh-toggle-card
    item: L_A1L_BIRD_EIN_AUS
    masonry: null
    grid: null
    canvas: null

Does it switch something - nope!
The ETS bus monitor is silent like the relaxing room in a spa.

Actually, I’m running out of time.

This is supposed to be ligthing control installation for a birds refugee. Although I did most of the logic on the KNX side, the OpenHAB/HabPanel installation is considered to be the control/monitoring station. I’m in the opinion, this is what OpenHAB is for… what else, if not?

Please help me - I have no problem to throw some money or other compensation in here.

I’m very much ok with the statement, that my combination (KNX, KNXD/Weinzierl) is not going to work stable - then I simply save the time and thankfully accept any alternative you may suggest. I do all this on my spare time and I donate the hardware to the refugee. This is why I’m unable to spend endless hours.


Are you really trying to use a “switch-control” or should the channel be of type “switch”?

If your device is a knx actor and you want to link the channel to a switching channel of the actor you should use “switch”.

Besides that I really recommend to leave the BAOS road and go for an IP interface. Running knxd introduces additional complexity and maintenance effort whereas an IP interface usually works out of the box after setting up the IP address. Think about how much time you spend on bringing the interface to life compared to the little money you may have saved…

Thank you, Thomas - that was the point.

Can you just give me one (or more:-) lines on that topic - for my current understanding: I grab a KNX-IP gateway (MDT, for example) and use the “same” KNX Bridge, however, not in serial mode but with an IP router/tunnel configuration?

As for the switch, thanks for the clarification but I’ve been through almost all the options:-))

You’re welcome.

IP interface works the same way, bit you define the bridge as as IP interface instead of a serial one.
No more knxd required. Usually the interface runs in tunnel mode. Routers are more expensive and I guess not required in your case.

So deleted the bridge you have defined and add a new one. Don’t forget to adjust your things configuration to use the new bridge.

1 Like

But I do need a KNX-IP gateway product?
Anything you can recommend or does it work with any product - I personally prefer MDT.

And I suppose that I can drop the USB Interface since ETS can talk to KNX by the way of the same gateway. Well yeah, all the network issue resolved, of course. The thing is, that on-site at the installation, there is no DHCP server and thus, the IP addresses are hand-picked. This is a bit “unhandy” coming with a notebook for some changes:-)

Yes. There are USB solutions as well, but prefer to be able to work from anywhere without cable connection (USB and serial in my opinion are outdated, but may have their niche where an IP network is not available or possible).

I’m running a Weinzierl 730 as fall-back and an a MDT SCN-IP000.03 which supports knx secure.

But in principle you may use any (I’d go for the MDT mentioned or one of its successors, works fine for me and has some additional features)
No need to go for the expensive ones with router support, tunnel is fine.

Let me throw in another question - for now, I’ve seen the RasPI as the host of the OpenHab system as well as the gateway to KNX (by the ways of the BAOS module). Since the BAOS module approach went south, I start asking what I need the RasPI for - the tablet PC is a full-featured Windows 10 system that gett’n bored just hosting a web browser. Is it possible to run OpenHab on Windows as a service and use the same system hosting the OpenHab UI in the browser?

That would pretty much clean up my actual installation…! :-))

Windows is possible, but you will get better support here if you run on Linux, especially if you use openHabian.

Question is if you really want to run OH on the same system that an end user has access to (and might break it - things happen).

A broken Raspi is replaced cheap within minutes whereas the Tablet is an investment…

An odd idea - I know. Especially for the case that I already have the RasPI installed and running - so I’ll leave it as it is… enough other things to do:-))

Thanks for the advice of leaving the BAOS approach aside - I’m now using the MDT IP Gateway and everything runs smooth like silk.