Kostal Pleticore 7 plus solar Inverter binding

Hi everyone,

I’m New to OH and i want to connect my Kostal Plenticore Solar Inverter to OPENHAB.

I found a binding plugin for my solar Inverter, but I’m Not able to get some data from the Inverter.

I’ve done same aß descripted here. Could there be a problem With the updated Inverter Firmware?

Bw

Maximilian

First, tell us a little more about your installation.

Hi,

I’m usingthis plugin (Version 2.4) with OH 2.4.0 on a Ubuntu LTS Server.

I’ve done the setup exactly how IT is described at the plugin Website, but I’m Not able to connect to the solar Inverter…

Bw Maximilian

Since you are new here, I need to ask. What version of Java? A common mistake is to use something newer than Java 8 which can cause issues.
That page does not say how to install OpenHAB properly.

java version “1.8.0_201”
Java™ SE Runtime Environment (build 1.8.0_201-b09)
Java HotSpot™ 64-Bit Server VM (build 25.201-b09, mixed mode)

The binding is really just a webpage scraper. Can you connect to the device’s webpage? Can your openHAB host? What does your Thing look like in PaperUI? What does openhab.log have to say?

Hi,

yes I can connect to the device website. If i add the binding graphically, i get an error that the connection to the inverter could not be established.

If i add the inverter manually, nothing is visible in PaperUI. I think, there is a problem with the plugin.

Is anyone able to connect to a new plenticore inverter?

Maximilian

I would think that the index out of bounds error would indicate that the binding has got a response/webpage that it cannot parse in the expected way.
Could be because the format has changed, could be a connection problem like a password.

OK i have also a Plenticore Plus and the same error

Status: OFFLINE - COMMUNICATION_ERROR java.lang.IndexOutOfBoundsException:Index: 4, Size: 0

Does someone have a solution for this? Password is the one i use for Web Page Access!?

Would be fine if someone can help…

Any solution on that? I have the same problem…

There could be a solution using the modbus TCP binding. I’ve tried this, but i was not able get some data…

Has anyone new infos to the Kostal binding?

BW Maximilian

Hi, i try to use a Plenticore 7 Plus via PaperUI discovery.

The thing has the state

OFFLINE - COMMUNICATION_ERROR java.lang.IllegalArgumentException:Malformed URL: 10.100.10.98

In configuration parameters i have to set a username, per default “pvserver”. According to the documentation for the new generation of Inverters you do not have to set a username. But the discovery process requests one?
I use the password set for the “Anlagenbetreiber” or “Plant owner”, for the URL i use the IP of the Inverter. Do you have any ideas?

Hi,

another thread helped me to solve the problem with the Kostal Binding.

Simple solution: Upgrade to openHAB 2.5.0.M4. The Kostal binding in this version is working nice with the current generation of a Kostal Plenticore 7 inverter.

BW

Hi, in my case it does not work with M4. Can you give me a screenshot of your settings?

Hi,

I set only the model, the ip address and the password and it works…

How do you set the model? Did you use the thing “Kostal Inverter” and the thing “KOSTAL PLENTICORE plus 7.0 (no battery)”?

UPDATE: I set up a new install of 2.5.0m4 and it works. Think my current install is broken.

UPDATE2: I did a little research: When installing the Amazon Dash button binding and the kostal binding at the same time, the kostal binding crashes when adding a new thing with server error 500 in paperui.