Kwikset 914 Inclusion

I am having a great degree of difficulty getting my door lock to be included in my z wave network. Maybe twice has it shown correctly in OH but the majority of the time it shows as “Node _” and “Unknown Device”.
I’m performing the inclusion process through Habmin and regularly have a new Thing discovered (and a handful of times the log showing “Device isn’t communicating”. I’ve tried everything I can think of to start with a clean slate: hard resetting the controller, factory resetting the lock, excluding and including the lock several times (through both Habmin and the “manual” way by unplugging the USB. When attempting the inclusion process I will set my Pi and controller on a stand with the controller touching the lock (tip from the Schlage thread), start the inclusion process through Habmin, press the z wave button on the lock, and add the newly discovered Thing in the UI. Often times there is some z wave chatter in the logs but the node usually just says “Unknown Device”

When I do get it connected correctly there is never any sort of chatter on the bus from that node when it is locked or unlocked (although the status light shows that it should be transmitting) and I have no control over it.

Is it really a matter of simply trying and trying again and again or am I doing somethign wrong?
Does the Habmin exclusion process perform the same actions as unplugging the controller and doing it manually or is it just removing it from OH’s bindings?
Is there a surefire way to make sure both the lock and the controller are excluded from one another?


Hardware: Raspberry Pi 2 model B
OS: Raspbian 8 (jessie)
Controller: Aeonlabs Z Stick Gen 5
Lock: Kwikset 914
Software: OpenHab2 2.0.0-1
Z-Wave: binding-zwave - 2.0.0

With the current zwave binding your installing via PaperUI or Habmin, the lock should include just fine…BUT the current binding does not have secure inclusion to actually control the lock.

There is a test binding in the works with Secure inclusion. The topic is getting long, but you can find download links and instructions to switch to this test binding here.

But both existing and test binding both have the lock in the database and should be found without issue. Sometimes I do have to stop and restart OH2 and scan for zwave devices a 2nd time though after it was included.

Thank you for the information! I was able to get my lock recognized again have simply left it there for now. I’ve read through some of the security threads and find it difficult to find current information. Thanks for including the link; I’ll have to see about changing over my binding to the test version!

Many of us have Kwikset locks securely paired and can control them with the test binding. But their are also a couple of known issues being worked out. 1) you can control your lock but most locks do not send back a status update. This can be ‘tricked’ with the Alarm Type code but that channel still needs to be implemented. And 2) there is still various delays in normal switches being update. Chris the developer is aware of these and is looking into them as well.

1 Like

I’ve found the snapshot .jar file but can’t seem to figure out how to get OH to recognize it. It should be as simple as dropping the file in /usr/share/openhab2/addons, uninstalling the old binding, and looking for the new one in the Add-ons in the Paper UI, right? Or am I missing something?

Sorry for spamming this thread. I found that I need to edit my addons.cfg file and have it set up as shown:
package = expert
remote = true
binding = zwave,chromecast,yamahareceiver,network,kodi,nest
ui = basic,paper,habmin

I’m now able to see my z stick is online and, in the thing menu it shows my chromecast and receiver are online as well. However, all of my zwave things all show “Initializing” with no change after 10 minutes or so of restarting the service. Should this eventually fix itself or is there more I have to do?

Additionally, on the Add-ons tab it shows z-wave as being installed but still shows the 2.0.0 version instead of the 2.1.0-SNAPSHOT I installed. Should this update with the snapshot?

You really do not need to be adding bindings to your addon.cfg file to have them start, and by doing that you possibly started both the current and test binding.

But follow these instructions here. The test Zwave binding does required to remove all existing zwave devices from Habmin/PaperUI and then re-add the. This is just removing from Habmin/PaperUi/OH2, and not actually reincluding them to your controller.

Follow those instructions and then check your log when restart OH2 as you probably will need to install the transport serial binding as well in Karaf with the test binding. There are instructions on that towards the top of that entire topic.

Did the link not post?

For anyone stumbling on this I’ll share what I’ve found.
To get this alternate binding to work do the following

  1. Note the names given to your nodes
    1b) If already securely paired with a device, go to the Z Wave controller and copy the Network Security Key
  2. Uninstall the z-wave binding
  3. Copy the jar file into the “addons” folder (/usr/share/openhab2/addons for me)
  4. Launch the console (‘ssh openhab@localhost -p 8180’ be patient, it takes some time the first time. Default password is habopen)
  5. Enter the command ‘feature:install openhab-transport-serial’
  6. In the UI, delete all of your Z Wave things other than your controller
  7. Check the Network Security Key of the controller; paste in the previous one if different
  8. Eventually your things will show up in the Inbox, add and rename them

I’m now able to lock and unlock my front door although, as mentioned, there are synchronization issues. The first time I told it to change state it acted as though it spun the motor in the wrong direction putting the deadbolt in a half in/half out state. I had to re-teach the lock which is in and which way is out and it now operates backwards (ON is unlocked, OFF is locked).

I’m also able to open my garage door using the Linear GD00Z-4 opener but the usage is somewhat strange. The Barrier Position uses an integer type and has to be typed in: 0 is closed, 1 is opened.

Hope this helps someone.