Latest iOS App Bugs?

Ever since the latest update of the iOS app (, I’ve noticed two bugs:

  1. The app won’t connect to my local url. I’ve confirmed the url, but it insists on connecting to the remote URL even when I am on my home network. The local url works fine in my browser.

  2. My Nest temperature setpoints no longer display the set temperature. They just say “0”. Again, they display fine in a browser.

Have these been reported and is there a fix?

Yep, others are having the same issues.

Ok. Well, if those who are working on the iOS app need more information or help, I’m available to them. Thanks!

Noticed one more bug, images are not refreshed when used as Image in sitemap (openab 1.8). Configuration is this:

 Frame label="Kamera Ulaz" {		
 	Image url="" refresh=1000

Worked without a problem on old openhab IOS app, image got refreshed every second. Now i only see the new image when i leave the frame and re-enter it.

Group Rollershutter is still shown as Switch Button and not as Rollershutter widget.

No push notifications. I see them in Notifications menu, but they not popped up. Before update it worked fine.

Regarding your first issue (not connecting to local URL) I can confirm that this solved the problem on my wife’s iphone:

Luckily I found this thread… I was going crazy trying to figure out what had happened to my push notifications.

Add me to the list of users no longer receiving them.

If you need me to test anything or provide any logs please let me know.

Same here with the iOS push notifications in the openHAB app. The notifications stopped on Wednesday around 4pm EST. I don’t see any errors within openHAB. They were working after updating to version 2.0 of the iOS app before Wednesday.

NO BroadcastNotificaton anymore since the IOS Update

Also no notifications anymore

Same here :confused:

Also Selection elements have incorrect selected items.


My iOS notifications started working again today!! Thanks for whomever fixed it. Much appreciated.

Old setup

Openhab 1.8.2, listening to localhost, Apache as Reverse Proxy in port 80, discovery never worked as messages did not make sense and were sent to a non wlan network interface. Old app worked with http://openhab-ip:80 not without port addition. My girlfriend is lucky to never update her apps.

New setup
Openhab 1.8.2, listening to localhost, Apache listening on port 80/8080 for http and port 443/8443 for https, discovery configured (servicediscovery:bind_address=…) and broadcasts _openhab-server._tcp with port 8080 and _openhab-server-ssl._tcp with port 8443. New app does not work with local url.

  1. manual entry of http://ip:port does not work - all combinations tried. directly tries to connect to remote url (which requires vpn connection)
  2. empty entry discovers but failes… but sitemap selection works…

sitemap request works:
192.168.X.XX - XXX [03/Jan/2018:21:54:38 +0100] “GET /rest/sitemaps HTTP/1.1” 200 704 “-” “openHAB/ CFNetwork/893.14.2 Darwin/17.3.0”

access does not work:
==> /var/log/apache2/error.log <==
[Wed Jan 03 21:55:49.427684 2018] [ssl:info] [pid 7468:tid 1967125552] [client 192.168.X.XX:60676] AH01964: Connection to child 1 established (server
[Wed Jan 03 21:55:49.429284 2018] [ssl:info] [pid 7468:tid 1967125552] [client 192.168.X.XX:60676] AH01996: SSL handshake failed: HTTP spoken on HTTPS port; trying to send HTML error page
[Wed Jan 03 21:55:49.429955 2018] [ssl:info] [pid 7468:tid 1967125552] SSL Library Error: error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request – speaking HTTP to HTTPS port!?

==> /var/log/apache2/access.log <==
192.168.X.XX - - [03/Jan/2018:21:55:49 +0100] “GET / HTTP/1.0” 400 0 “-” “-”

I would like to disable the auto discovery as it confuses my setup totally and breaks the app. If I would understand the code, I would help out, but I did not find anything useful in the sources…

Hope that analysis helps :wink:

Since a week or so, my dynamic icons are not reflecting the real state anymore. I already rebooted but no result. No change has been done to the config and Android/web/… are behaving normally

Same problem here, besides no charts. These bugs only appear when accessing through
Charts without legend in OH2.2 and iOS client
Also, legends in charts don’t work in iOS.

I can confirm this. When using the IOS app on local Network, all icons shows correct state and change correct.

Wrong icons using happend recently, within last 1-2 weeks, so it is related to something changed in that period.

Therefore, it cannot the IOS app, which was changed earlier. Maybe @digitaldan has the overview to identify where this problem came from.

Was somebody already able to solve this?

Yes, it is solved now. The icons in the IOS app is working fine both with local and remote access.