Latest Zwave binding missing module?

Tags: #<Tag:0x00007f616ee3e730>

It also could be the case that nothing else in their setups is referencing anything from com.thoughtworks.xstream, so it might not be loaded by the framework. That could be confirmed by installing another binding (using Paper UI or addons.cfg) that uses that package. I dunno for sure.

Took me a while yesterday to find and install the dependencies for the new mail binding. I wanted to install the binding jar in an early 2.5 snapshot, and it was a bit of trial and error to find the right 3rd party jars I needed to install. :confused:

My mail service provider disabled TLS 1.0, which broke the OH1 mail action. I was unable to send emails from my production openHAB install, so I was desperate for a solution…

I doubt that’s likely - XStream is used to read all the thing definition files in the core, so every binding uses it. Unless of course that’s all changed now to use a different XML parser - possible, but that would be quite a significant change.

Hi Mark,

copied the xstream-1.4.jar to addon folder. No output in the logs.
copied latest zwave snapshot to the addon folder, behavior as before:

2019-05-05 15:32:21.886 [WARN ] [org.apache.felix.fileinstall        ] - Error while starting bundle: file:/usr/share/openhab2/addons/org.openhab.binding.zwave-2.5.0-SNAPSHOT.jar

org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.zwave [259]

  Unresolved requirement: Import-Package: com.thoughtworks.xstream; version="[1.4.0,2.0.0)"

	at org.eclipse.osgi.container.Module.start(Module.java:444) ~[?:?]

	at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:383) ~[?:?]

	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundle(DirectoryWatcher.java:1260) [10:org.apache.felix.fileinstall:3.6.4]

	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundles(DirectoryWatcher.java:1233) [10:org.apache.felix.fileinstall:3.6.4]

	at org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess(DirectoryWatcher.java:520) [10:org.apache.felix.fileinstall:3.6.4]

	at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:365) [10:org.apache.felix.fileinstall:3.6.4]

	at org.apache.felix.fileinstall.internal.DirectoryWatcher.run(DirectoryWatcher.java:316) [10:org.apache.felix.fileinstall:3.6.4]

Hi Chris,

could you please tell me where to find a zwave.jar that is able to recognizing all my new FGR-223 Fibaro Roller Shutter, but also old enough not to run into this… very special problem with this xstream stuff?

Thank you very much!

Since I don’t know what the problem here is, I can’t really answer - sorry. There is no archives of JARs, so if the M1 version doesn’t contain your devices, then there won’t be any other option I’m afraid.

thats a pitty, anyhow, if you like me to try something with my setup let me know

In the Karaf console, what do you see when you run this?

list -s | grep xstream

In a recent 2.5 snapshot (build 1587), I see this.

openhab> list -s | grep xstream
 65 │ Active │  80 │ 1.4.7.1               │ org.apache.servicemix.bundles.xstream

In an older 2.5 snapshot (build 1502), I see nothing.

If this bundle is not installed, try dropping this jar in addons.

http://central.maven.org/maven2/org/apache/servicemix/bundles/org.apache.servicemix.bundles.xstream/1.4.7_1/org.apache.servicemix.bundles.xstream-1.4.7_1.jar

5 Likes

no output…

copied xstream-1.4.jar to addon, restarted, no output using list -s | grep xstream

same for 1.4.7_1jar

Hmm. That’s odd. When I drop it in addons, I get this.

openhab> list -s | grep xstream
261 │ Active   │  80 │ 1.4.7.1                │ org.apache.servicemix.bundles.xstream
$ ls -l /opt/openhab2/addons/org.apache.servicemix.bundles.xstream-1.4.7_1.jar 
-rw-r--r-- 1 mark mark 548391 May  5 10:01 /opt/openhab2/addons/org.apache.servicemix.bundles.xstream-1.4.7_1.jar

I’m gonna try putting the latest zwave binding in my build 1502 addons directory to see what happens.

1 Like

but!

afterwards I copied zwave.jar into addon folder and it works
seems to be that 1.4.7_1.jar is the solution for me

Thanks a lot!

Excellent! Glad that got it sorted out.

Please mark my post above as the solution.

I think there’s also a way to install that bundle directly from the console by specifying the maven coordinates, but I haven’t figured that out yet.

openhab> bundle:list -s | grep zwave
262 x Active   x  80 x 2.5.0.201905050432     x org.openhab.binding.zwave

looks good!

1 Like

Hi all,
Same for the Zigbee binding.

last xstream pass a step but now starting the bundle require gnu.io

@MacFly What’s the exact message you’re getting in the log?

243 ? Installed ? 80 ? 2.5.0.201905050432 ? openHAB Add-ons :: Bundles :: ZigBee Binding
244 ? Installed ? 80 ? 2.5.0.201905050432 ? openHAB Add-ons :: Bundles :: ZigBee Telegesis Bridge
245 ? Active ? 80 ? 1.4.7.1 ? Apache ServiceMix :: Bundles :: xstream
openhab> bundle:start 244
Error executing command: Error executing command on bundles:
Error starting bundle 244: Could not resolve module: org.openhab.binding.zigbee.telegesis [244]
Unresolved requirement: Import-Package: org.eclipse.smarthome.config.discovery.usbserial

openhab> bundle:start 243
Error executing command: Error executing command on bundles:
Error starting bundle 243: Could not resolve module: org.openhab.binding.zigbee [243]
Unresolved requirement: Import-Package: gnu.io; version="[3.14.0,4.0.0)"

it seems I’m not able to mark your post as a solution…
no checkbox…:frowning:

@rlkoshak Is it no longer possible to mark a post as the solution?

@MacFly Hmm. I’m not sure what to suggest about that. Sorry.

It have worked on friday, to shame i deleted the files …
anyway thanks for your answer