Ledvance Smart+ Outdoor Zigbee pairing but not working

I finally got my new Ledvance Smart+ Compact Outdoor Zigbee. I’m using OpenHAB 3 with BV 2010/10 using the Zigbee binding.

I tried pairing the device with OpenHAB, and that worked quite well – the device was found and the Switch channel was detected. However, when I change the status of the plug using the button on the side of the device, OpenHAB apparently receives no information on the status change. The device is shown as online until I try to change the status of the OpenHAB channel – at this point the device goes offline.

Here are the log entries I’m getting:

2022-05-16 22:45:43.539 [INFO ] [bee.discovery.ZigBeeDiscoveryService] - F0D1B800001C4621: Starting ZigBee device discovery
2022-05-16 22:45:43.541 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing 'zigbee:device:01382828:f0d1b800001c4621' to inbox.
2022-05-16 22:45:44.073 [INFO ] [bee.discovery.ZigBeeDiscoveryService] - F0D1B800001C4621: Starting ZigBee device discovery

==> /var/log/openhab/events.log <==
2022-05-16 22:45:43.542 [INFO ] [openhab.event.InboxAddedEvent       ] - Discovery Result with UID 'zigbee:device:01382828:f0d1b800001c4621' has been added.
2022-05-16 22:45:49.649 [INFO ] [openhab.event.InboxRemovedEvent     ] - Discovery Result with UID 'zigbee:device:01382828:f0d1b800001c4621' has been removed.
2022-05-16 22:45:49.657 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'zigbee:device:01382828:f0d1b800001c4621' changed from UNINITIALIZED to INITIALIZING
2022-05-16 22:45:49.663 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'zigbee:device:01382828:f0d1b800001c4621' changed from INITIALIZING to UNKNOWN
2022-05-16 22:45:50.056 [INFO ] [penhab.event.FirmwareStatusInfoEvent] - Firmware status of thing zigbee:device:01382828:f0d1b800001c4621 changed to UNKNOWN.
2022-05-16 22:46:02.056 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'zigbee:device:01382828:f0d1b800001c4621' changed from UNKNOWN to ONLINE
2022-05-16 22:49:25.540 [INFO ] [openhab.event.ItemCommandEvent      ] - Item 'Ulkopistorasia_ON_OFF_PLUG_IN_UNITSwitch' received command ON
2022-05-16 22:49:34.965 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'zigbee:device:01382828:f0d1b800001c4621' changed from ONLINE to OFFLINE

Any ideas why this is and how I could debug the problem? I get the feeling that this is some kind of compatibility issue with the device, not a malfunctioning device, but is there something I can do to try to fix this? Finding an outdoor plug was quite difficult, it seems to be pretty much the only model out there.

What coordinator version are you using? Possibly it’s too old and may require a newer firmware if the device is a Zigbee 3 device.

I think you were right! The coordinator version was something in the area of 5.8.0. I managed to upgrade the coordinator with NCP_USW_EM3587_6710-LR.ebl to and once I got over discovery of new thing will reset the baudrate of the BV2010/10 · Issue #726 · openhab/org.openhab.binding.zigbee · GitHub the Ledvance outlet works perfectly. Thank you!