Leviton VRI10-1LZ issues

Aeon Labs ZStick Gen 5

I’m trying to install a Leviton VRI10-1LZ dimmer. The Z-Stick includes it but it stays grayed out in Habmin and I can’t add it to a sitemap. Looking at the information of the device in Habmin the library type, protocol version, and application version are all listed as “Unknown”.

The Device ID is 209 and when I search online for information I come to this: VRI10-1LZ issue where they state that 209 won’t be added “for now”. Does this indicate that the device isn’t in the binding database?

Let me know any information I can give (and how). Relatively new to openHab and not sure how to find the things you need.


If the information in the device attributes shows unknown, then it means that the binding hasn’t been able to talk to the device. Either it’s out of range, or it’s not included properly. I would suggest getting a debug logfile and loading it to the online log viewer to see what is happening.


I’m trying to figure out how to get the log but is seems the device is included and it is only about 10 feet from the Pi/Stick.

Here is a pic of what I see in Habmin:

Was able to grab a log and load it in the log viewer but it just says Message Retry for that node. Does this look like an inclusion problem? I’ve tried to include it about 4 times.

I can only really restate what I said. The device is timing out, which means the controller can’t communicate with it. Either it’s too far away (which seems unlikely if it’s only 10 feet) or theres an inclusion problem and it’s not really included, or the device is broken. Maybe there’s something else that I’m not thought of, but these are most likely I think.

I don’t know what to say.

I excluded it from the ZStick (which I’ve included other switches and plugs with no issue) and included it with the Vera sitting right next to the Pi and it included in 10 seconds and worked no problem.

Looking at the database for the “VRI10” it says that information is missing and in fact the library type and protocol version are not in the database.

Another thing, even though it is showing in Habmin as an assigned node, no node.xml file is being created for that node. Not sure if that means anything more but I figured I’d mention it.

Worst scenario I can always run this dimmer off the Vera as I need to keep it for my locks but I’d rather move everything off I can. I’m going to have other similar dimmers soon too so I’d like to see if I can get this working with the ZStick.

Wanted to add, I installed the Zensys diagnostic tool on my Windows computer and it looks like the switch and the ZStick are actually talking to each other in the log that tool has.

Can you confirm how you added the switch to the Zstick? Did you pull it out and bring it over the switch to add it? Or add via habmin?

I have a few of those switches and have added them just fine in OH1. I have yet to move fully to OH2 yet. But I have always added the switches by bringing the ZStick over to the switch.

You could try and remove the device from the Zstick and then airgap the device to reset it and then try and readd it?

I did it all, bring stick over, tried via Habmin, and air gap. I reincluded with Vera (included in seconds and functioned) and removed again to make sure nothing was left over. I even excluded first before an include.

Almost all the info is there except the three things I pointed out. Using the diagnostic software on Windows the Stick is sending info and the switch is replying. No idea why it isn’t working on Habmin.

I’ve seen in various places that Leviton has multiple device ID’s for these switches which led me to suspect it not being in the database.

Also, Habmin is showing packets sent and received as of 7 minutes ago (and it’s been included for hours).

Can you confirm your actual Switch Model number? Is it a VRI10-1LZ like you mentioned?

I live in the USA, and all of my Leviton Switches start with a DZ model number. Perhaps your’s is the same as mine, but sure.

I only ask I do not actually see that in the OH2 device list.


Yes, that’s it. Leviton has two models of Zwave dimmer/switches. The VR which are like the Cooper switches/dimmers and also work with their Vizia RF controllers. When Home Automation started getting popular a few years ago, they released another line that was significantly cheaper (but missing instant status) to compete with the likes of Linear and GE. I think these have the DZ designation.

Leviton -VRI10-1LZ on Amazon

On Chris’ device list it lists a VRI10 (missing the “-1LZ”) that seems to match but has the note of incomplete data.

This doesn’t matter - it’s only for information. OH2 uses some of the data, but OH1 is totally irrelevant.

If you can provide a log, then I’ll take a look at what’s happening - based on the limited information I can’t really say much more, but as suggested above, the log viewer should show what’s happening.

Here you go Chris. I believe this is what you’re looking for. I followed the instructions on the binding page.

Node 24 is the one in question.


Zwave log file

The issue is that the device is not responding to the version request.

In OH2 there is a database option to force the version to get around this issue. I’ll look at porting this to OH1 - please can you raise an issue in the OH1 tracker.

Glad I wasn’t going totally insane! Thanks Chris!

Excuse my Noobness, but where do I raise the issue? Would it be here?


Yes - for OH1 that’s the right place.


Ok, done. Issue #4616.

Do you have the XML file for this device (the one OH creates in /etc/zwave)? I ideally need this to update the database…

That was a strange thing. There was no .xml created. I now have the dimmer back on my Vera. Not sure what info you need, I can see if it’s listed there.

Yup, just tried to put it back on the ZStick and no .xml file for that node. My .xml files are in /var/lib/openhab/zwave no sure if that’s because I used apt-get or there are other files somewhere else. That’s the only place I found them.

I can try using the diagnostic software on my Windows PC to get the info you need too.