Lgwebos Binding Can't Initialize

Hey all, so I imagine I am just doing something stupid, but I have been banging my head on the wall trying to figure this out for a few days now.

So the problem is, when I try to connect to my lg webos tv I can’t get it to get past initialization. No Pairing notification will pop up on my tv. I can however get the lg tv plus app on android to connect. With that it pops up a code on the tv that I have to type into the app.

Here is what I tried:
Started with openhab on a pi3, installed the lgwebos and wake on lan bindings through paper ui.

The first time I tried pairing I did it through paper ui auto discovery. This first time everything did actually work, it popped up a accept/reject dialog on the tv, I accepted and I had control over everything except power on.

So then I decided I wanted to control all of my things through config files, so I deleted the tv from my things list, reset pairings on the tv and built a things file with this line:

Thing lgwebos:WebOSTV:bedroom-tv “Bedroom Tv” @ “Bedroom” [host=“10.xx.xx.2”, key=""]
host is the ip of my pi and key is the key that appears in paper ui’s auto discovery.

This just ends up with the things stuck in initializing. No dialogs on the tv

Then I thought, “ok thats not working, let’s just do it through paper ui, that worked right?” So I tried it again through the paper ui. This time and all subsequent attempts it has the same problem as the config file, just sits in initializing, No dialogs.

I have tried this on a pi, and a docker container on my server, both have the same problem.

Any Ideas?

is this your public ip?
you should use the private local ip instead.
better remove the ip from this post.
here everyone can get your address

No that’s the local ip of my pi.
And, no they cannot get my address. They can get the address of my service provider.

Yup, I was just dumb. host should be the ip of the tv not the pi. And I omitted the key parameter, seems to work just fine so far. Not sure what that should be. For some reason adding the tv through paper ui still doesn’t work, but that is fine for me.

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.