LGWebOS Binding (for LG WebOS TVs)

When you say that it did not fix my issue, you are not talking about your problem that frequently if the TV was recently turned off, the command would turn the TV back on ? Because of course my fix is not about this issue, so there is no reason it could fix it !

I have the feeling I already noticed your issue. Unfortunately, now that I try to reproduce it, I can’t. After a first command that power off the TV, if I send again a OFF command to the power channel, the TV remains OFF.

You are correct @Lolodomo. My issue is the TV comes back on (after an OFF command via my a Harmony hub rule) if I send another OFF command via my Good Night rule.

As I mentioned, if I wait for a few minutes before running the Good Night rule, the TV will stay off.

It finally happens again to me lkast night when I go to bed.
I will add few lines of code to avoid that.

@swamiller : please try with my last test version, our problem should be fixed now.
You can find the jar in this PR (use the last of course):

I installed the latest jar, I’ll test it out tonight and report back.

EDIT: Seems to work, @Lolodomo! I’ll try again tomorrow to be sure, but first shot looks good.
EDIT 2: I’ll call this one fixed. Second night, no issues.

Thank you!

@Lolodomo any chance of sharing a link to the explanation Sebastian mentions?

@swamiller : for your information, the fix for your problem has been merged and so will be available in the next release.

1 Like

@wlaw : I published few screenshot in the change to explain it.

The remaining channel is the TV channel number but options are dynamically built for this channel and this allows showing TV channel number and TV channel name in UI.

Keeping a second channel for the TV channel name was useless with this enhancement.

1 Like


I have a working binding but after every openhab restart it is pairing with LG tv again because I didn’t set a valid key in the thing configuration. I didn’t get it when I successfully connect, I only get a 403. How do I get the key?


@Lolodomo Thanks. I can now see what you have done and I think it is an improvement. I had previously done something similar merging TV_channel number with TV_channel name using rules.

The difference wasn’t immediately obvious to me because my site map used Text to show the TV_channel. Using Text you only see the integer part of the TV_channel. Changing from Text to Default gave the same display you have posted.

Once again, thank you.


Default or Selection widget to get the option and so channel number + name.
Text widget to get the state without the option and so only the channel number.

HI all,

Bit of a random one that I can’t see mentioned above, (although I have to admit to not reading every 730 posts), I’ve got a night time routine that runs at midnight every evening, doing things like turning the cameras on, tv off etc…this works great, but on the odd weekend evening we might want to stay up later, (dirty stopouts that we are), so at the moment I just grab my phone, open the OH app and turn the routine off…

However, is there a way to have a yes / no or ok option appear on using this binding, (I already have it showing messages but I need an interaction option), ie if the TV is still on then if we want to delay the routine then at midnight the TV shows a prompt, if we click yes, the routine runs and we go to bed, if we click no then it sends a command back to OH and I use it to delay the routine in a rule…

Hello @sprehn. I have the exact same issue. Following your advice I checked permission for lgwebos folder. Permission seems to be correct. I have:
drwxrwxr-x+ 2 openhab openhabian 4096 Feb 10 2019 lgwebos

However there is no file at all into that folder. Could I create it manually to fix my issue? If not, how to proceed to reinstall everything correctly? I tried several time to just delete the binding and install it again without success.

If you are using a 2.5 version there is no need for a lgwebos folder anymore. recent versions store all info in OH. are you using a thing file instead of auto discovery? you would need to set the key that you received after pairing. u find it in the paperui thing details

OH 2.5.4 is now available and it includes several improvments for the LG webOS binding, like in particular the WOL feature integrated in the binding. You don’t need to use the WOL binding anymore. Rather send the command ON to the power channel.

1 Like

This is all great, however I don’t know if the following is an issue with my configuration or the new update.

Previously when turning the tv off with the remote/auto shut down (timeout). The tv_power switch would flip to off. Now it seems this switch does not flip to OFF when the TV is turned off by any other means than Openhab.

This means that I now (unlike before) can get the TV state in Openhab out of sync with reality :frowning:

(Or maybe I’m actually running 2.5.3, maybe missed the latest upgrade with a few hours)

Edit: I take it all back. I updated to 2.5.4 and now it works. It seems it worked for me on 2.5 Milestone1, but not on 2.5.3, but now on 2.5.4 it’s all good :+1: :+1:

1 Like

I was on 2.4. So, I updated to 2.5 but I got a lot of error related to mail, mqtt, weather, system info and many others binding. CPU raised at a level so high I was not able to make anything work correctly or apply any changes. I will have to take each problem one at a time but probably later and in parallel with my current stable 2.4 version. So I got back to 2.4 now. Knowing I don’t need any lgwebos folder with 2.5 version, is it the same thing with 2.4? To answer your other question I always used auto discovery.

easierst will be if you are loosing the pairing anyhow. just stop OH. delete the folder (or move it). start it again and check if a new folder is created.

Hi Sebastian, in my log I have the following warn:
2020-04-23 00:06:57.499 [WARN ] [ebos.internal.handler.LGWebOSHandler] - Unable to handle command REFRESH. No handler found for channel lgwebos:WebOSTV:341fb9b3-7e83-df32-5651-30190b025c1c:channelName. This must not happen. Please report as a bug.

2020-04-23 00:06:57.790 [WARN ] [ebos.internal.handler.LGWebOSHandler] - Unable to handle command REFRESH. No handler found for channel lgwebos:WebOSTV:341fb9b3-7e83-df32-5651-30190b025c1c:channelName. This must not happen. Please report as a bug.

I started from 2.5.0, now I’m on 2.5.4 OH and I had always this WARN.
Can I do something?



The channel channelName was removed as channel now comes with options to show number and name in one. pls unlink the item