LIFX Binding with multiple networks / Scanning Wrong Subnet

Hello, I have openhab running on a server with two networks:

Wired Ethernet: = Main Network
WiFi: = Private non-routable network for Smart Devices

On the WiFi interface I am running hostapd and dhcpd so it acts as an isolated network for all WiFi based smart devices (not Z-Wave) to connect through. I do this because I have trust issues with all these IoT vendors, you never know what kind of stuff they may be doing or what kinds of info they want to transmit home. The Wifi private network is non-routable and has a firewall blocking everything in on the WiFi interface (other than the required services/ports).

When it comes to the LIFX Binding I originally joined the LIFX bulbs to this network and can see them, ping them, etc. I’ve even updated the FW to v3.42 prior to adding them to this private network make sure they are current. One thing when it comes to the LIFX Binding using PaperUI, whenever I scan for new LIFX devices it comes up empty. Doing a packet capture I can see the scan is only being done on the primary network and NOT the private network.

hostname.http-alt: Flags [P.], seq 494:987, ack 99, win 2057, options [nop,nop,TS val 971412468 ecr 1772180839], length 493: HTTP: POST /rest/discovery/bindings/lifx/scan HTTP/1.1

Is there any way to configure the LIFX Binding to bind to a specific subnet?

It should already broadcast the discovery packet using all broadcast addresses. Periodically it updates the broadcast addresses being used. As you can see in the code it skips down/loopback interfaces. This logic should be part of the binding since openHAB 2.2 or newer (ESH PR #4231).